The new Crafted Primals don't save to the Wardrobe

I have crafted Demon’s Demise for my Nat’s set. I save it in the Wardrobe. I then switch to my GoD set that uses a Primal Fortress Ballista. And when I switch back to Nat’s the Demon’s Demise is replaced with the Fortress Ballista and I have to manually re-equip the Demon’s Demise.

The same thing happens with my GoD that uses a crafted Primal Squirt’s necklace. Though it’s saved in the Wardrobe, when I switch using the wardrobe the crafted Primal is replaced by an ancient Squirt’s Necklace.

The reason for this is because the Armory swaps out one item at a time instead of removing all the items at once and then replacing them, only it does it very quickly so it seems like it does it all at once. I think it was designed this way to prevent dropping everything on the ground if your stash and inventory were full.

In your case it is attempting to equip a crafted primal before first removing the other one, and you are not allowed to wear 2 at the same time.

You will run into this problem if you use the same legendary gem in different slots, or if you wear the same ring on different hands across different armory profiles.

The solution is to always use the same slot for the crafted primal, or always wear the same ring on the same hand or always use the same gem in the same slot. Or, you can just remember to always hit the Load button twice.

It has been reported ever since the armory was first introduced, so I don’t think they intend to change it. It is not really a “bug” per se, it is just how the armory works.


That’s all fine and dandy but Crafted Primals aren’t the same as regular Primals. And even if that is a reason, then no item should be placed instead of the wrong item all together.

It is attempting to wear 2 crafted primals at once, and it can not. So it skips that item and moves on to the next.

If they are going to change it at all, then they need to just make it work properly with duplicates, but I don’t think that is going to happen.

Again, that doesn’t explain forcing a Fortress Ballista into where it doesn’t belong. I could see if I had another Demon’s Demise and it was using that. But equipping the wrong item is a bug no matter how you cut it.

Can you record a clip showing it in action?

It happened to me consistently last season when swapping between builds where one used a sanctified weapon, and the other used a sanctified quiver, but it would just fail to swap the quiver out, not put a random item in its place.

I wish I could. I mean, I’m sure I could somehow but I’m not very tech savy and I’ve never made a video before.


I am sure you will not be the last person to report it this season.

You can try to always use the crafted primal in the same hand, or just always remember to click “load” twice. It sucks, but they have chosen not to change it.


So hitting load twice will put Demise where the Fortress Ballista is? Oh okay. I can do that. I’ll give it a try. If it’s as easily remedied as that, it’s not that big of deal.


Yeah, that solved it. I’ve just never experienced that issue before with the Wardrobe. Thanks for helping me out.


I hadn’t had that problem, so I went back to check.

There’s a good reason I’m not experiencing this:

  1. Unhallowed has Crafted Primal Yang’s.
  2. Marauder’s uses the same Crafted Primal Yang’s.
  3. GoD has a Crafted Primal Ballista in her right hand and Ancient Dawn in the left.
  4. Nat’s has the same Dawn, but in her left hand and a Crafted Primal Demise in her right.

So, I guess I’m just lucky the way I equipped her gear. And I always save the build if I make even the slightest change.

It’s too bad Blizzard can’t come up with a better way to manage the Armory.


I suspect it also has to do with you not having any jewelry that’s crafted primal in builds. I think weapons are replaced at the same time and everything gets replaced in a specific order.

It’s just weird because my GoD uses a Squirt’s while my Nat’s uses Endless Walk. You would think because it’s replacing both the weapon and jewelry it wouldn’t have this problem.

In my case, I had the following:
Profile 1: regular weapon, crafted quiver
Profile 2: crafted weapon, regular quiver

When swapping from profile 1 to 2, it worked fine because it removed the quiver before trying to equip the crafted weapon.

When swapping from profile 2 to 1, it would fail to swap out the quiver because I was already using a crafted weapon.

I am not sure the exact order of all the items, but last season would have been a good season to have tested it.

1 Like

Well, as @VitaKaninen stated, it depends on the order in which items are swapped out.

I don’t know if that information can be found anywhere. I know that the order of items picked up and equipped when you die and go back to click on your Corpse in D2 is documented. (I think on Maxroll, but I’m too lazy to look for it).

I no programmer. But, how hard would it be to replace all items at once.

1 Like

You would think it would be easy enough, but as I said in my first post, I think it was designed this way to prevent dropping everything on the ground if your stash and inventory were full, but who knows for sure.

All they would have to do is make it automatically attempt to load the profile twice when you click “load”. That would solve the issue.