The game connection has been lost: your client has been disconnected from the server


#1

I get this error when I try to start a private game or join a public game. I have no issues logging in and viewing my characters.

I have tried restarting my PC, reinstalling the game, running both 64 and 32 bit versions, checking for updates/repairing the game, and resetting my router.


#2

Hi there Mjsud,

This sounds like something is blocking the connection to the game. We can make sure by trying with a new character, if still an issue, then lets move to some connection troubleshooting.

First, I would look for any local firewalls. Things like an Anti-Virus or ports on the router or modem can cause a connection block.

After this, another step that is not supported, but is helping others, is to turn off IPv6.

This step is not supported by us, and if it works, the ISP will need to be contacted.

Let me know if this helps!

/Nathardrick


#3

I’ve been getting this since season 18, frustrating, especially when i was in a goblin portal and it dc’d me halfway thru the map.


#4

I posted something similar on the EU forums: https://eu.forums.blizzard.com/en/d3/t/unable-to-play-on-mac-since-2-6-6-update/223

The recent update to support season 18 (patch 2.6.6.61291) broke the game for me. I can view and create new characters but starting a game loses (or never obtains) connection with the game server. I was playing quite happily before the patch and have gone through all the connection FAQ suggestions to no avail, so I am convinced that it was something that was introduced by Blizzard unfortunately.


#5

Also been encountering the same. Had purchased and was not able to play Diablo 3. Friend happened to have a key so I gave it another shot.

Experiencing the same as well when it comes to being in game. At least I’ve been able to play and then all of a sudden it gives me a connection error for whatever reason.

I have a Gen 4 I7 laptop and I’ve been able to play other games reliably.


#6

Have the same problem here ever since the patch and recent updates. Have been playing smoothly before. now I can’t play for more than 10 minutes without disconnections … have tried everything else and sending a web ticket to Blizzard didn’t solved the issue.


#7

same issue here, europe server
wanted to finish season in last days, and cant login to games