PTR Patch required

Game updated completely
Did a scan and repair
Checked for updates
Did a reinstall

Still the same message;
A patch is required the game will close; and apply the patch.

Is there an upgrade done which has not been released yet or is it a bug

PTR game version;

Game updated just now after i Checked for an update

same for me still can not get in

Same here. I was able to access it when it launched, and no problem for a few days, then I took a break, came back now to see the changes, and I can’t get in. It keeps saying it needs to update and quits, but neither forcing an update (just tells me that it’s up to date), nor a scan and repair (at the end it pretends to update, but does nothing), nor uninstall-reinstall, nor deleting the PTR game folder altogether solves this. I’ve tried running the launcher in administrator mode, redid all that, nothing. I also did 5 consecutive scan and repairs, just in case it’s an issue of small, interdependent updates, didn’t change anything. I’d really like to try out the new changes to Inna and the monk ethereals, but how do I get past this?

Silly question, but have you tried rebooting then launcher as admin scan and repair? Sometimes I have to do that to get the launcher to update. Why reboot? I don’t know, but it can help. Another thing that can cause the issue is security software if it blocks the update.

Thanks for the suggestions. I vaguely remember that I had the same problem in the last PTR, but then it went away on its own. Well, I had a power nap just now, and just now when I checked in the launcher, the PTR version was updated to a higher version. I launched the game and it logged in without a hitch. So to anybody having the same kind of problem, my advice is this: start the Bnet Launcher in admin mode, and just leave it running, don’t try to manually make it update the game, it will seemingly only do it on it’s own :sweat_smile:

1 Like