Need advice on mastering Helltooth Set dungeon

I’m trying to work my way thru all the class sets and finally earn those wings. Some sets seemed hard at first and turned out to be easier than I expected. But Helltooth is just the opposite. Of course with Mara’s Kaleidoscope the “no poison damage” is automatic. But I find it nearly impossible to group the monsters together for the 20 kill requirement. The dungeon is all windy corridors with clumps of 8 or so… if I do anything but run past them they die and if I do that they don’t stay aggro’d. I cleared it multiple times with my best run being 2 of the necessary 4 group kills. I tried following the build setup on but it’s still either “kill or fail to aggro”. Is there a guide that actually works?

If you’re killing them as you run through, ensure you don’t have Thorns on your gear.

Well that’s a kick in the teeth… the set dungeon is bugged.

I was able to gather 20+ monsters with NO damage besides Wall of Death (no thorns, pets, etc.) I cast Wall of Death and watched the total monster count drop from 280 to 255 and…

Nothing. The game randomly decides whether or not it will award the kill achievements.

Thanks for the video, the Chicken build works much better than the build but when the game is broken it’s not much help.

I found an old thread from last May reporting the exact same problem. Nobody seems to care that this achievement is broken. Typical Blizzard bull carp.

After more than 15 attempts with the Angry Chicken build I finally got one that worked properly. The first 4 mobs that I aggro’d and hit with Wall of Death actually registered properly. I then summoned the zombie dogs and the gargantuan and quickly ran the map to clear it. I should note this was AFTER I upgraded to 2.7.2 so maybe it was fixed? Because it was exactly the same thing I did every previous run that failed.

As someone that’s got mastery of every single dungeon, I can assure you it’s not.

Well good for you.

I’m not the only one seeing this problem. I’m glad you don’t. But it happens, repeatedly, to me. Nothing I do gets the game to properly record the kill achievement. That it works for you is COMPLETELY meaningless for me.

That’s kind of the point of it being a bug.

For example, when did you get the achievement? Perhaps something broke in a build since then that caused this problem. Players with the achievement are unlikely to go back and run it again for no reason.