Marauders set not applying bonus under RORG


Hi team
My DH was using the 6-piece Marauders set, and I decided to use the cubed RORG and swapped my helm out for a Visage of Gunes (for extra damage and the abiity).
As soon as I did that, it seemed that I lost the bonus for having sentries out, and damage was significantly reduced.
I tested this by swapping the Marauders helmet back on and damage returned to normal.
Character is called Noparlez in my account, and is seasonal.
Would you please take a look at this when you get a chance?
Thank you.


There is no bug with RoRG. Either you swapped more than 1 piece out, or forgot to use the ring. Try again.


Nope. RORG was cubed, only swapped helm. Tried several times, result always the same.
If it’s not the RORG, then it’s the Visage or the Marauders. Take your pick. I can repeat this flaw all day long.


Post a video of it, showing your gear and cube powers. It works for me just fine.


How nice for you. Just because it works for you doesn’t mean it isn’t for me. Please don’t be so dismissive.
What’s the easiest way to record a video? I have played for years, but have never done so.


Most “bugs” reported here are user error or people not understanding game mechanics. Unless there is something wrong with your game files, the RoRG is not bugged, neither is the M6 set. If RoRG didn’t work with marauder set, then the countless players using N6M4 would be howling on this forum.

Windows 10 has built-in game recording using game bar. Nvidia has GeForce Experience. There are other freeware game recorders but I haven’t used them, I just use Win10.

If you think there might be something wrong with your game files, try doing a scan and repair through the bnet app.


Thanks, appreciate it, just being playing with recorder in Geforce Experience.
I’ve done a repair and rebooted my machine - this seems to have made a difference. I’ll keep testing and update in a little while to confirm.
I’ve never recorded my game before, never had the need, but if this persists then I’ll have a video to post and link to.

All right. That appears to have fixed things. Funny, I haven’t reinstalled for a couple of years and things had been pretty smooth. Maybe I’ll start from scratch again just to freshen everything up. Thanks TimberWolf for the suggestion.


He is dismissive because we have seen this “bug” posted about 100+ times, we still have yet to see one instance were it’s not user error.


Here’s at least one instance.

I have the same problem with my Maruader’s set. I am using 4 of the set items and decided to make my whole build around the set (even though I have better individual options for set armor), including making most of my skills the ones mentioned in the 4 set bonus (e.g. chakram, multishot), but my sentries still do not seem to copy those attacks. I thought maybe it was because I was in town so I went and played a bunch with them, and they still never copied my attacks. I thought the bug might be an issue with a specific rune I was using with the sentries, so I switched it out, but my sentries still never copied any of my attacks with the mentioned skills. I tried using Blizzard’s “scan and repair” tool since that worked for FizgigNZ, but it did not detect any problems (and why would it anyway, I just installed the game from scratch a few years ago because I haven’t played it in a while).

Blizzard, can you fix this?
If this is “User Error”, can anyone actually be helpful and explain to me the error?
I would upload a video but I do not see how to do that in this forum.


If you make an attack when the turrets don’t have an enemy in range of them they don’t replicate your attacks. This is why they don’t fire anything when you’re in town, for example, as there are no enemies there. However, when there’s an enemy in range, and you’re using a replicable attack, they’ll fire, as shown here…