Lag and stuttering on good computer


#1

Hello, I’ve been having trouble with performance on Diablo and I was wondering if anyone could help me out.

So to optimize my games I’ve been using the GeForce Experience app, I optimized the game using the app then started playing. I noticed some screen tearing, looked in the settings and turned on V-sync. It seemed to solved one problem but added another.

Every now and then if a lot of enemies are on the screen or loot, and every time I entered a new area, I got FPS drops, down to 30-50.

I don’t think it’s a problem with my PC
I have a GTX 1070ti, i7 8700k, 16gb DDR4 and I have Diablo on my SSD. I have no problems playing games like GTA or Battlefront 2 on max setting.

If anyone might be able to help please or give suggestions please reply if you could. Much appreciated


#2

Are you using a Razer (Synapse) mouse and/or keyboard ?
If so, see if upgrading to the Synapse-3 Beta helps. If not, uninstall the “Razer Chroma SDK Core Components” using Windows 10 Settings / Apps / Uninstall. See Known Technical Support Issues - [Updated July 3, 2019!] (and the post just above that one) for more details.

If you’re not using Razer drivers… using the GeForce Experience optimizer can sometimes create problems… I’d stay away from it. Try to reset your in-game options and see if it helps :


#3

I’ve had wonderful performance for 6+ months up until this (week of 5/8/2019) now I’m getting terrible stuttering, rubber banding, etc. Computer and broadband provider have not changed. My connection stats (ping, download speed, etc) are currently the best I’ve seen in a while. This used to be a much more frequent problem that mysteriously went away. Now it’s back. My guess, as it’s always been, is overloaded servers on Blizzards end or a defect introduced in an update. Just need to wait for the servers to be fixed or an update to correct. This has happened before and has mysteriously corrected itself with no action on my part. I’m betting next week things will be back to normal.


#4

im having same problem since forever and i gave up fixing it. My conclusion is that it has to be some issue with internet connection and not any hardware related problem. But then again my ping is always around 60 and it doesnt go up while stuttering. I also play with V-sync on and that locks my fps to 60 but during stuttering, fps doesnt go down. It stays at 60 no matter how many effects or mobs are on screen. It also happens in town.


#5

Hey there,

If things still aren’t working after trying what Boubou suggested, please grab a DxDiag file and post it on pastebin. Once it’s posted please provide us the code for the link.

Example:
pastebin.com/abc123

We’d need the numbers/letters after the slash.


#6

Doesnt matter, I have used about 8 different computers since d3 was launched and everyone had stutter on this game and fps drops. Just bought a new one with rx 570 and ryzen 5 1400 and still same results and on ssd. Other games play fine though gta v, warframe, play 10+ hours a day on those not a single stutter or fps drop but this game does. Also have lived in Texas, Louisiana, and currently in North Carloina all with best internet I can get in those areas but that doesnt effect fps drops.


#7

has anyone found solution to this kind of stuttering? i was doing some changes in nvidia control panel but havent solve anything. It still happens in same way no matter what i do.

But one thing i also noticed is this stuttering is occurring in a cyclical manner… like game or server is doing something in the background and that is causing this stutter/fps drop. and the time frame at which this is happening is always same. I dont think its a lot of enemies or new area that is causing it


#8

Hi there,

Turn off all your comunitie channels. This is old and well known issue that still is in the game. With it on I cant play the game. If I turn it off it works well. Try it.


#9

im in 0 communities and in no clan also so this is not the problem.

but check this out. I did a silly test in game just to prove that im on something here.

as you can see in my post above i said this stuttering/fps drop is occurring in a cyclical manner and that the time frame between 2 fps drop events is exactly same every time and as it turns out i was correct.

what i did was i vent to act 5 and as i was running around the town i was using stopwatch to measure time between each stutter events and i did that for 10 cycles and the result was always same. 2 min and 8 sec was the time between each screen stutter and it never failed to happen in this time frame. Now i know this is weird but believe me its so damn annoying to play the game like this. Btw the stutter lasts for around 6 secs.

Now i was thinking a lot about the possible reasons why this is happening and i could be wrong about what i said in previous post that enemies or new area doesnt have effect on this but they might have because in rifts its happening more often so it has to do something with processing data in the background and that is causing this fps drop… but then again it isnt really a fps drop because during the stuttering fps stays same.

if there is a genius that could figure this out i would be grateful.


Micro Stutter Problem
#10

Try turning Vsync off. If that fixes the stutter, then you know it is a an issue with the game getting the graphics info to your card. Do you have a lot of background apps running?


#11

i dont have any unnecessary program running in background.

when i turn vsync off, my fps goes to around 120 and almost never drops below 100 but then screen tearing is there because i have monitor with only 60Hz refresh rate so playing with vsync on looks way smother… outside of this stutter that i get every 2 mins of course. But anyway stuttering doesnt go away with vsync off… the game just plays worse.


#12

I am having the same issue, vsync stutter without tearing or choppy :frowning:


#13

Hi; maybe game goes cyclo-stuttering 'cause game is not synch’ed with desktop resolution (Hz) . Time-regularity of problem might be due to different Hz rate , example: if you are playng fps 60 and desktop Hz is 70 , you might need to match them manually to get the same Hz rate(60 in fps, 60 in desktop, 60 in game res) 'cause every pc differently manages graphic inputs and sync. Try to set in game fps, desk res and game res to the same Hz rate and see if it makes some difference. There might also be network problems due to your Internet provider , but by the moment it is regular i suppose it s only a Hz problem.
Regarding to the V-sync it depends on the graphic card/configuration you have on the machine, just try enabling/disabling and then choose what is best for you.


#14

“Hey, y? all prepare yourself for the Rubberband Man
You never heard a sound like the Rubberband Man
You? re bound to lose control
When the Rubberband starts to jam”

Nothing New Sadly :confounded:


#15

I was getting this initially. I lowered the background and forground FPS under diablo 3 options, display settings, to 60 and the trouble seemed to go away.


#16

Game’s been laggy for me post patch as well, with random disconnects.


#17

Im getting the same lag spikes today, yesterday was ok.
As I cannot have links in a post, here are the stats from Speed Test App
Ping 8 ms, Download 475 Mbps, Upload 58 Mbps, Jitter .43 ms 0 Packet loss
Just to put me off I had 4 - 5 bounties ready to hand in, waiting for a friend to login.
There is nothing wrong from my side.


#18

This very obviously won’t help everyone, but I am hopeful it will help someone. I started this game and it was absolutely unplayable. My entire computer ground to a halt. Mouse, keyboard, video, audio - everything. I looked at resources, and nothing was particularly spiked. So I started killing unnecessary processes. If this sounds like your problem and if you have the Oculus Rift application running in the background, kill it. This totally and immediately resolved my issue.


#19

Ok. I’m back with an update since my post from 5/8/2019 where I was having bad stuttering after season 17 started. As expected the stuttering went away within two weeks and everything was great UNTIL the last update and the start of season 18. Here we go again with the start of season stuttering. Time to go away again for two more weeks until the “mysterious” patch is applied or people get tired of season 18 and the servers are no longer stressed.


#20

Extra laggy for me as well since patch 2.6.6 and “entering game” always crashes on first attempt