Images in Inventory are loading too slow

It takes too long time to load images of items in inventory and stash. Sometimes it takes more than a minute.

imgur(dot)com/a/t6Qbq6t

Please don’t make us have to fix your screenshot links before we can see what you’re trying to show us. Thank you.

To post a link to your screenshot:

  1. Upload your image to a free image-hosting website, like Imgur.
  2. Paste the "Direct Link" to your image in your post. (See image below).

  1. Select the link you just pasted and click the ˂/˃ button on the Reply Editor toolbar. (See image below).

  1. Click Reply. (See image below).

Your link will look similar to this: https://i.imgur.com/T4Zsmoe.jpg


Fixed and embedded yours:

No matter how I am trying to post link into a post, I get the error message “Sorry, you can’t include links in your posts.” That is why I had to post that link that way.

Have you tried disabling antivirus software?
If that helps, add D3 folders to the exception list (whitelist); or, turn on the Game Mode if your antivirus has it.

You need to convert the link to preformatted text (steps 3 & 4 of Perusoe’s reply) in order to post links. Follow the steps… you’ve already done Step 1.


As far as slow inventory, are you on a Mac by any chance ? there is an old topic on the Mac Technical Support forum here:

According to that topic, changing the Texture Quality from Low to High seems to work for some players. See the post by betaSavvy here:

Blizzard had requested that players with that issue post their system specs and info… you may want to add yours as well as a comment on whether changing Texture Quality helped.

1 Like

In addition to system specs, can you share with us if you are using the 32-bit or 64-bit client app? If you’re running 32-bit, we’d like to know if you are experiencing this issue on the 64-bit.

1 Like

I am a Mac user, and was one of the ones that had this work as a fix previously. However, with the new patch, it has recurred and with some oddities. I’ve noticed that characters that were not part of season 21 do not have the issue unless they are wearing a fair bit of season 21 gear.

When this started again after the patch, I tried changing the video settings again to no avail. Following another suggestion in the Mac thread, I cleared the D3 Data folder and the entire PTR folder and freshly installed the game - again no effect.

Currently on MacBook Pro (retina, 13 inch, mid 2014)
Processor - 2.6 GHz dual core intel core i5
Graphics Intel Iris 1536 MB
Mac OS Catalina 10.15.5

Hope this gets figured out and glad Blizz looking into it.

1 Like

Same problem here :frowning:, but after more than 5hrs of research, tests, reinstalls (game and drivers) i got somewhere, so…

The problem IN MY CASE exist ONLY on 32-bit D3.
And the best part is, for me it’s caused by…
SPECIFIC LEGENDARY POWER IN CUBE.

What I mean is…
As long as i’ve “Depth Diggers” selected in my cube as power (season, non-season - doesn’t matter) i’ve slow loading images in inv, stash, npc and even teleporting between locations takes like 2-3 times longer than it’s supposed to take (on SSD).

Surprisingly…
Turning off “Depth Diggers” in cube INSTANT fixes EVERYTHING.
I can wear them w/o any problems, but if i put and select them in cube, BOOM.
I’ve no idea If this problem occurs ONLY with “Depth Diggers” or there are many other powers in cube that bugs things. (Could test more than just “Depth Diggers” on standard, but i don’t have time right now :worried: )

And…
Yes, problem only exists on 32-bit client, even on PTR.
There is 0 problems with any bugged/slow loading images/textures on 64-bit with those pants on.
Tested on 3 different PCs (Win7, Win10, 32-bit, 64-bit, different video setting, different languages), same results.

I don’t know if patch 2.6.10 did this or not.
I was always on 32-bit D3, because surprisingly i’ve more fps and better graphics there with the same video settings. And… i don’t remember “Depth Diggers” as power in cube causing any problems.

2 Likes

I can confirm the 32 bit part. I don’t know why I run the game 32 bit all the time, propably because of an error I had way back in the earlier days. No idea what error, it’s been too long…

I got depth diggers way too late this season, the lag started before that. Although I can’t really tell the exact moment, I can at least confirm that the extreme lag has something to do with the Cube.
However that 32 bit client already had lag issues way bevore that, I wasn’t even aware of those. Several seasons ago I started noticing drop lag (somewhen S10 or bevore that, can’t really tell more accurately… at least I can say it was some time after the introduction of UE). That means, that items get drop animations, but don’t actually appear on the ground until some seconds later. That didn’t bother me too much, since I usually only noticed that when the DB drop was missing. However that also randomly happened with other items too, from all kinds of sources (monsters, chests,…). That seems to apply to all items from random treasure classes, since all DBs or all Craft Materials from several sources appear at once when you just wait for the drop to appear for a few seconds.

All that above and also some other lag I didn’t notice bevore (game seems to run much smoother with the 64 bit version, less loading time of areas) is the issue of the 32 bit client. My ping is still the same, my client is still the same, can’t really be anything else. Or are there system specifics where you could say that the 32 bit client runs just awfull in general?

The odd thing for me is, on the 32 bit client, there is no problem in ACT 2. Also, I don’t have Depth Diggers in the cube. Only Ambos Pride / Mantle of Channeling / Band of Might / Obsidian Ring of the Zodiac. I can also confirm the problem goes away when running the 64 bit client. Although I get a smoother framerate with the 32 bit client. I get micro stutter in rifts using the 64 bit client. Very annoying.

How do you change from a 32bit to 64Bit? Do I need to reinstall?

A checkbox in the launcher’s settings controls 32/64-bit.

No, you do not need to reinstall because both versions have already been installed.

1 Like

1 Like

Hi, I’m running d3 (32bit) on Win 10.
I had already experienced the same problem during Season 21.
The fix was to change the Texture Quality to High. Everything will load instantly.

Now Season 22, same issue happened to me again.
Changing the Texture Quality does not help at all.
Only fix is to run the client in 64bit and everything loads fine.

Hope Blizz fix this issue quickly.

1 Like

I don’t have that option under settings…:frowning_face:

Could you post a screenshot please?

I cant seem to attach the picture. All I see is the D3 logo and then a check box for “additional command line arguments” and the option to select the Text&spoken language. Below that are two buttons to “modify install” or “reset in game options”. Maybe I m wrong but do MACs even have the option for 32/64 bit? Also I tried deleting all the files in Data under the D3 folder and reinstalled. The issue remains. I also changed the in game graphics like recommended. Nothing worked.

This is the system I am using:

Model Name: MacBook Pro
Model Identifier: MacBookPro14,3
Processor Name: Quad-Core Intel Core i7
Processor Speed: 2.8 GHz
Memory: 16 GB
Graphics: Model Name: MacBook Pro
Model Identifier: MacBookPro14,3
Processor Name: Quad-Core Intel Core i7
Processor Speed: 2.8 GHz
Memory: Intel HD Graphics 630 1536 MB

I m running macOS Big Sur, ver 11.0.1

To post a link:

  1. Upload your image or video to a free hosting website, like Imgur or YouTube.
  2. Paste the "Direct Link" to your image and/or video in your post. (See image below).

  1. Select the link you just pasted and click the ˂/˃ button on the Reply Editor toolbar. (See image below).

  1. Click Reply. (See image below).

Your link will look similar to this: https://i.imgur.com/AQIKfWw.gif