How do I move the location of D3PREFS.TXT out of OneDrive?

I have 3 Blizzard accounts (Prometheus#2318, Sorceress#21143, Tinkerbell#21539) of which Prometheus and Sorceress is used primarily by myself on my Desktop and Laptop computers. The Tinkerbell account is occasionally used by my niece when not at school.

The issue I am experiencing is with Prometheus#2318 and Sorceress#21143, and the storage location of the D3PREFS.TXT file on OneDrive.

I have setup the Microsoft OneDrive option to redirect the Desktop, Pictures, and Documents folders to my OneDrive to allow the availability of work from the Desktop computer on the Laptop, because they both use the same Microsoft OneDrive account.

This has however had the unfortunate effect of overlapping “copies” of the D3PREFS.TXT file usually located in “C:\Users\USER_ACCOUNT_NAME\Documents\Diablo III”.

Because D3PREFS.TXT resides on “OneDrive\Documents”, both installations of Diablo III are now attempting to use the same D3PREFS.TXT file. The biggest issue is regarding graphics settings.

The issue is created because on the Desktop, I play Diablo III (Sorceress#21143) at a video resolution of 1280x720 (for performance reasons despite being capable of running at 1920x1080) and I use a specific keyboard layout to facilitate play. I make use of the laptop (Prometheus#2318) when I am traveling, but with it not being a “gaming” laptop, it is only capable of playing a maximum resolution of 1366x768 and must also use a different keyboard layout.

If for whatever reason I need to go someplace and take my laptop with me, and then find time to play Diablo III, and then later return home, I find that playing on the Desktop reverts to a default graphics setting of 1920x1080. This is likely because the video card does not support the 1366x768, which I then have to manually reset back to 1280x720.

This “shared D3PREFS.TXT” also makes it necessary for me to always double-check my key bindings depending on which computer I play. That is because while both computers use QWERTY layouts, the Desktop is a full size keyboard with separate cursor control keys in between the alpha keys and the numeric keypad. The laptop lacks those and possesses only the alpha keys and a numeric keypad.

This issue occurs regardless of which account (Prometheus#2318 or Sorceress#21143) I use on which computer, desktop or laptop.

I have tried using MKLINK to “re-direct” the “Diablo III” folder to a location outside of “OneDrive\Documents”, but that did not work and created more problems than it solved.

My question is this: Is there any way for me to tell each individual installation of Launcher and Diablo III where to find “private” copies of D3PREFS.TXT so that this overlap can be avoided?

Moving “Documents” back to a default location is not an option, as it facilitates a work requirement that it remains within OneDrive.

Thank you for you time, and hoping for a speedy resolution to my problem.

You will probably have to keep two different D3PREFS.TXT files, and label them A and B…or whatever works for you. Then depending on the computer you’re using, you’ll have to edit the file name each time so the appropriate one’s title reads just D3PREFS.TXT.

It would be nice if there was a command line switch you could append to the game file on each pc, that would load the appropriate D3PREFS.TXT file for you.

Perhaps a script, or .bat file to run when you click play, and have that load the D3PREFS.TXT for you?

I don’t know how you would go about doing those things, though. If you figure something out, would you please let me know?


There should be an option within OneDrive and it’s account management to select folders to not sync. Microsoft should have the steps listed here that you can check out!

Thank you, I have applied the suggested settings on my Windows 10 computer (desktop) and unchecked the “Diablo III” folder.

However, when I move to my Windows 11 machines (laptop) and follow those same steps, the “choose folders” button is disabled/grayed out…?

Hey Sorceress,

The greyed out/disabled buttons you most likely will need to reach out to Microsoft support for. More than likely there is a permissions or account setting that needs to be taken care of!