Holiday event not dropping gifts (Switch)

The first time playing the event, I got a few gifts. Since then, I’ve run multiple ancient vaults, and probably 40-50 GRs without one gift. I saw others are having the issue as well. I’ve exited the game and restarted the console to try to fix, but nothing.

1 Like

Have seen it on PC where you could like 3 o 4 GR’s with no Gifts. I had it one time go 2 or 3 Vaults with no Gifts. When they 1st started it. You were getting one almost every GR. You would 2, 3, 4 or more in a vault. But have seen now where is not dropping like when it 1st started.

I play with a friend and we didn’t get not even a gift yet. We did at least 20 ancient vaults and a lot of gr (we don’t 90 in 2:30 min aprox) together but not a single gift


So, I had this same issue.

It first appeared after I completed this week’s Challenge Rift. All of the sudden, Holiday Gifts would not drop.

Similar to you, I ran a ton of Greater Rifts (about 15), and a ton of Ancient Vaults (about 10).

Possible that it’s variance? Sure, but it seems improbable, especially since I’ve never had this bad of luck on any other platform. I decided to switch to my Hardcore character, and in 3 Ancient Vaults, I managed to get a couple Holiday Gifts, and was receiving Holiday Gifts in Greater Rifts.

I quit and restarted the game, and went back to my Softcore character, and reran a few Greater Rifts (about 5) and Ancient Vaults (about 5), and nothing. So it seems that it gets a character stuck in Holiday Event limbo.

Anyway, I did manage to get this resolved. This is probably too many steps, and can be optimized, but this is a step by step of what I did after.

  • I created a new Softcore Character.
  • I then started the game with the new character.
  • I switched back to my original Softcore character.
  • I changed the game mode to Campaign on Normal Difficulty (instead of T16), and started that instead of Adventure Mode.
  • I then went back to Adventure Mode on Normal Difficulty.
  • I ran an Ancient Vault in Normal, and lo and behold, a Holiday Gift dropped.
  • I then switched to T16, and ran another Ancient Vault, and saw Holiday Gifts dropping again.


OK, I’ve got this resolved to a simple step.

EVERY time you start the game, first start in Campaign Mode. Exit out of the campaign, back to the menu, and then select Adventure Mode. This seems to correct the issue, allowing you to get Holiday Gifts.

I’m still trying to figure out how to get the game into the dropless state at the moment, and why that happens.


This totally worked! Thank you!!!


So, I found a video which found out the reason. (I can’t really link it, because it contains some stuff which violates the rules of the forums.)

Apparently, if you start the game too quickly, the patch won’t load properly. They suggest to wait 30 seconds at the character select screen when you first start the game. This is why the gifts also disappear. But if you wait 30 seconds before entering the game, the patch is loaded, and you can start receiving gifts, and the gifts won’t disappear out of your inventory.


Game is closed
Start the game, get into adventure mode immediately: Patch not applied, gifts missing
Start the game, wait 30 seconds, get into adventure mode: Patch applied, gifts there
Start the game, get into campaign mode, then switch to adventure mode: Patch applied, gifts missing
Start the game, wait 30 seconds, get into campaign mode, then switch to adventure mode: Patch applied, gifts there
Exit the game completely, start the game, get into adventure mode: Patch not applied, gifts missing
From a working state, exit just to the menu, where you have to select your profile again, get into adventure mode completely: Patch applied, gifts there

Also, switching to campaign after you’re in a broken state apparently corrects the patch, whereas just exiting back to the menu, even changing from HC to SC, or SC to HC, changing characters, etc., does not seem to work.

So, you start immediately, enter adventure mode, patch is not applied, but then you switch to the campaign, then go back to adventure mode, you can start collecting presents, but your previous gifts are gone.

Conclusion: I think starting in campaign mode is just the best approach here, as it guarantees the patch is loaded. I’m not sure why the patch can fail if you just choose to load in adventure mode.

Also, perhaps this can be duplicated on the other consoles? This would probably require an original PS4 or Xbox One with the slower hard drives, which, unfortunately, I don’t have access too.

1 Like