Goldstreak Bug Switch

Hi Guys,

my wife and me want to complete the conquests. Goldstreak / Bosskill in 20 min / GR 45.

We are hanging on the goldstreak and it will not work.
I run 25 Cow Rifts with Smaragd in Helm and got 100 mio. Gold but the Goldstreak does not trigger. Tried already with templer - he has a Gold Armor but still not working.
Even in good small Nephalem Rifts no chance. Tried with 2 Chars DH + Barb - nothing. Sure I have to Goldgem everything should work.
it worked without any issues in the past seasons. This season it fails.

We deactivate our pet and leave the gold untouched and collect it after everything is done. Nothing.

Now we thought maybe the switch is to slow and we collect 40 T16 bounty bags.
We stay in town and unbox it without movement and pet was also deactivated, we earned over 70 mio. at once - guess what, the conquest is still open.

Any Idea where is the issue?

1 Like

This Forum is for reporting Bugs on the PC version.
There have been no reports here of problems completing Avarice/Avaritia.
It must be a Switch issue and Consoles have their own Bug Report and Discussion Forums.
Edit: I see you moved it to the correct Forum.


The goal is not to pickup 50 Million gold in game… it is to accumulate 50 Million in a streak. On the PC, the streak is displayed to the right of the resource bubble… as in this screenshot:


Yepp - I know that. I did it in the past very often :smiley:

Good – I wasn’t sure, so I thought I’d put that answer in.

Then, you’ll want to post in one of the Console forums, as suggested by @yessquire above .

Good luck with this.

P.S. : you can move this entire topic to either the Console Discussion or the Console Bug Report forum… instead of creating a new one. Scroll up to the top of this topic and click on the pencil tool at the right of the title, as if you wanted to modify it. That will give you a drop down box with categories… select either Console Discussion or Console Bug Report as appropriate.