Game kept on crashing with patch 2.6.10


@AOman: Same as what ?

  • @RGSL is reporting crashing in Crystal Arch (en route to fight Diablo)
  • @MuPpeR is reporting crashing in Great Span (en route to fight Izual)
  • @N64AU is reporting crashing while using Zombie Bears in a Greater Rift
  • @Cisek is also crashing in Crystal Arch, but on a PS4

Same as OP on PC. Crashing in Great Span, I have a portal created there, as soon as I move it crashes. Or if I take the main portal it crashes immediately.

Same with me. I cant play atm

i have crashes when try to look some players profiles… not all time… but randomly! game frezze … in windows task manager i look on diablo status “not respond”… only helps to remove the task in the task manager! problem started with the patch 2.6.10 only ((

I came to report the same bug as the OP. I tried it using a DH and Barb while helping someone get a Necro achievement. Changing the game difficulty or running solo also results in the same crash.

To “work around” the crash that occurs after walking up the stairs in the Crystal Arch, start the Prime Evil quest at the beginning and run all the way through to Diablo. So kill Izual and then Diablo. Not a satisfactory solution, but it’ll work until the bug is fixed.

hey everyone wanted to chime in to let you know that we’re aware of the issues mentioned in the thread. As always, please feel free to continue to share any bugs/issues especially with crashes. If you have steps to repro, that is SUPER helpful.

thanks all - ill keep you posted


Words of hope have been spoken. Our quest is stood waiting for the next patch.

1 Like

my game crashed yesdarday on stream twice (( i try to make some short video on my twitch channel and posted link here if possible

1 Like

It seems that each time I save progression in ACT IV it crashes after.
But if you start in ACT III and keep going trough ACT IV then you don’t crash.

Crash to Win 10 desktop after logging into D3 and using the waygate to Great Span


1 Like

Hi, thank you Rich for your reply. Within the group of people I’ve been playing with since the patch, each one has had several crash-to-desktop events. If it helps, we have only been running Neph rifts and GRs. All crashes occurred within those areas. We were unable to find any pattern as to what was causing them.

Adventure Mode, Act II, City of Caldeum, heading towards Belial.
At the top of the stairs, crash to desktop.
100% reproducible.

Crash ID

Campaign Mode, Act IV, Fall of the High Heavens, Begin Quest.
As you approach Tyrael, crash to desktop.
100% reproducible.

Crash ID

Radeon HD6700 series
Windows 10 64 bit build 19041.572

1 Like

Crash ID : B52FF4BF-42AE-4705-8D0B-303613180D1E

Game crashed in a Greater Rift on Europe

I see a bug the forth cube slot hasn’t been permanently added to the game

Yes, 3E3AC290-96CE-4BE4-9967-CC911A953D79 for me.
Nvidia Geforce 1060
Win 10 64bit

E079290D-00E3-4BD4-9774-90A74FAC2E96 This is the Crash Report I am getting when in Act 4 my guess it is the same for the rest of you… I have updated my Graphics card to the most current and still nothing.

It’s nothing to do with your graphics drivers. This is affecting PC users whether using nVidia or AMD cards, and console players who clearly don’t have the variance of graphics cards PC users do. This is something introduced with Patch 2.6.10 that Blizzard will need to fix, hopefully by Tuesday, in time for Season 22’s start because, if not, it will prevent the completion of the Season Journey and some Conquests.

Campaign mode, Gardens of Hope 2nd tier on the quest the Light of Hope to find portal to the crystal colonnade.


My Monk tried to get to Great Span and four times the game crashed.
Last code was 18947C05-443E-42BF-8BD8-8BCE16971715.
Tried to use both types of the portals with same result.
Yesterday game works (not in that zone).

First I tried to fix it.

  1. I rested the cache folder.
  2. I used “Scan and Repair” option in the App for Diablo III.
  3. I downgraded the graphic card driver to the last official Windows 8.1 x64 version Crimson ReLive Edition 17.7.1 from AMD. Normally I use the Windows 7 x64 Driver under Windows 8.1 Pro x64.
  4. I upgraded the Radeon Software to 20.11.1. I used the Windows 7 x64 driver.
  5. I run the “dism /online /cleanup-image /restorehealth” command to check and repair the Windows 8.1 Pro x64 component store.
  6. I used “sfc /scannow” to check and repair Windows 8.1 Pro x64
  7. I checked the partition D:\ with the “chkdsk /F”.

None of these steps solved my problem.

If I start the Quest “Fall of the high Heavens” I got a crash if I go to Thyreal. The problem is 100% reproducible.

If I start the quest “Heart of Sin, kill Azmodan” and end them I can change to Act V. After the port to Act V I can end the quest “Fall of the high Heavens” without any issues.

The issues started with patch V2.6.10

I got a another crash if I start in the adventure mode. If you start in Act I and you try to port to Act II “City of Caldeum” you also got a crash.

D3Debug.txt If you start in Act I and you try to port to Act II “City of Caldeum” you got a crash.

D3Debug.txt Crash if you start with quest “Fall of the high Heavens”.

Crash Report ID: 0B8D714E-F2D4-4C1D-943F-A2AC2FBA2037

My System:
CPU: AMD Phenom II X4 965
GPU: Radeon RX 480 8GB V-Ram
RAM: 2x 4GB DDR3 1600MHz
Motherboard: Asus M5A99X Evo R2.0
OS: Windows 8.1 Pro x64