Do you old timers remember this? Diablo (1) on Battlenet

I did not think the original disk would have that much at all. Blank CDs back then were like 750mb I think? Although now that I think about it, if the original installation was in the low 100’s it makes sense that so much would run off the CD, videos would run off them at the time as far as I remember.

This original disk talk just makes me think how it was a mistake to not keep mine. I kept all the games from back then for a while afterwards but sadly didn’t think it was necessary to keep them later on. At least I still have my original Brood War.

You can still salvage that purchase using devilutionx (I use it even with the GOG version, it’s better). Widescreen support and lets you press alt to highlight items on the ground.

1 Like

The original disk has a lot of other .DLL files on it. Plus the manual, Smackplayer, install, video file extras, DirectX7, etc. The resource file (MPQ) for the game itself is 505,373kB. My disk is a Battle Chest version because my first one developed a crack in it.

A CD is 700MB but you usually can only burn 650 MB on it because of reserved space.

1 Like

Back in the day, I could never get Diablo 1 to run on my P90. I’d be lucky to get to watch the intro cutscene but the game would always crash when trying to load the menu screen. Guess my computer wasn’t good enough.

I’m afraid if I get this, I’ll have trouble running this on a computer that’s now too good :rofl:

I still have the original Diablo CD somewhere.

Was running it on an AMD x86, Pentium wannabe. 14" monitor!

Still have the original CD. Absolutely love this game. I ripped the music from it and burned the MP3s to disc so I could listen to it anywhere.

Favorite memory… Remember the old Boba Fett Trainer?

I started a public game wtih Boba Fett set to full god mode. I ran down to Diablo killing as few as possible so I the game would remain open to as low level as possible. I cast a town portal and waited… Some poor dude joined my game as a level one and chatted “Cool! Can I take your portal?” I said “Come on down”.

Of course he gets whacked but was cool about it. “Oh sht! Diablo!”.

He laughed about it and said “Good one, man”.

1 Like

Thank you for sacrificing Hamilton to find this information out. Aaron Burr would be proud.

:smiley:

1 Like

Yeah, it seems that GoG’s D1 version is much more stable and user friendly. I’ve had GoG’s D1 for a while but I’ve never played multiplayer with it. So I tested it out.

It worked for me. Initially, I got the port 6112 error that others have reported, however, all I needed to do was forward the indicated network ports and GoG’s Battlenet multiplayer ran perfectly. Made a character, made an account, and once in, made a game. Granted, there’s no one on D1’s Bnet atm so I couldn’t test joining a game.

So yeah, I agree, buy from GoG for the time being. It connects to the same Battlenet as Bliz’s version so it’s not like the two are split up.

The very existence of the enhanced version in GoG’s package makes it worth more than Bliz’s (since they are the same price).

2 Likes

This forum should get a D1 clan going :rofl:

1 Like

Kick that :poop: lol done now

Back in SC2’s heyday, the forum regulars formed a clan called SFP - SC2 Forum Posters.

There were ~100 members at its peak. lol.

Yeah. I forgot I have a different modem/router combo now. I had to log in to my modem gateway and add the Custom Port Forwarding Service again. It didn’t help.


Actually, it looks like it is trying to let me in. But, I was getting the same thing before I added the Custom Port Forwarding Service.

I’m not getting the Port 6112 error. After selecting my Battle․net Character I get a log in window with blank buttons and empty log in fields.

The problem is, I don’t remember what information to type in the fields. It seems like it required retyping the name of the Character. But, I can’t remember what to use in the second field.

Huh, that’s a strange one. Here’s the UI with the text on it:

This is the old Bnet so you’d need to remember the name/password of your char(s) way back then. There was no chance I was going to remember, so I just made a new one.

Did you put the full range in? 6112-6119?

Yeah. But, you only need to add the Custom Port Forwarding Service if you’re seeing this:

And that’s not what I’m getting anymore. (On Blizzard’s copy or GOG’s copy).

I was curios just in case the other ports besides 6112 were messing with the login screen. But it sounds like they don’t.

1 Like

Hopefully, Blizzard and GOG will eventually fix the issue. In the meantime, I don’t play in groups anymore. For Diablo  I’ll play Single Player. If I want to play my Multiplayer Character, I’d rather run GOG’s high-resolution version anyway.


As far as Blizzard’s copy goes, I found this thread on their Legacy Games Technical Support forum, started 3 days ago: Diablo 1 Multiplayer not working

But, I guess you know that.

For the record: The DirectDraw support article didn’t work for me. I tried:

  1. Running Diablo  from the Battle․net Launcher.
  2. Running Diablo  from Diablo.exe in the installation folder.
  3. Running Diablo  from DiabloLauncher.exe in the installation folder.

All with the same result.

The TS thread you linked is for an update loop that some people get stuck in, but that happens before the Bnet logon screen.

The Direct Draw issue happens even earlier when the game is initially opening, so long before the Bnet login.

You’re making it to the Bnet login so it seems that those two aren’t what you’re experiencing. In fact, you’re the first that I’ve seen to mention the missing text.

If you want to at least get it down ‘on paper’ for Bliz to see, drop a description over in that Legacy TS forum.

1 Like

Maybe, just maybe they’ll get some free time and Frankenstein the D2:R graphics wrapper engine, reuse/create new graphics assets and remaster D1.

So anyone who buys it, keep complaining about the problems, maybe they’ll do something about it eventually.

:man_shrugging:

Yes. This is what I experience when running Blizzard’s copy. (Sorry I wasn’t more clear on this).

  • GOG’s copy is letting me in to Battle․net. But, the Account log in screen is blank fields and buttons. (Just checked and still is).

  • Blizzard’s copy was putting me through the update loop. I went in, just now, to get some screenshots of the message windows. But, Blizzard’s copy is working now. I am now able run D1 from the Battle․net Launcher, select Battle․net, select my Level 37 Rogue, create a new Account and get into a Multiplayer game.

Maybe it was adding the Custom Port Forwarding Service that fixed Blizzard’s copy. I’m not going to worry about it.

So, my current situation is:

  • When I want to play Diablo  I will play GOG’s high-definition version.
  • If I ever decide to play Multiplayer with friends again, I’ll play Diablo  from the Battle․net Launcher.

At least now I don’t feel like I threw $9.99 USD away. (Sorta)


Actually, this one is a GOG issue. But, thanks for the tip.

I ended up making a windows xp VM on virtualbox just to try this online stuff lmao.