Devour doesn't work during Land of the Dead

Yesterday I found out that Devour doesn’t work during Land of the Dead (it should be unlimited during that time). Is this a bug? Or was this skill nerfed? Because I tried that on vanilla (off-season) and it worked as it should. I’m sad, I can’t play because the skill doesn’t work. Does anyone have such kind of problem? :frowning:

Typically (if you’re using numlock devour) when you cast LotD devour doesn’t work until you manually press the key. Then it seems to work just fine.

This can be more easily tested using the pestilence set. If you don’t hit devor after hitting LotD you won’t get any lances, but as long as you hit it once, you’ll get a steady stream of lances. Personally when using LotD with devour, i manually cast devour, it feels better.


I have the same issue as the OP, I love the Znec build for group runs and I have to click the mouse to have the lances go off I use the Maxroll build but for Devour I use it as the aura ( because I’m lazy) and none of its working.

Yeees. It’s been broken for a week. But still no fixes, just pray and hope someone from support will notice it.

I had the same issue untill I realized it was the angelic power consuming all the corpses. I’m playing znec with num lock on devour just fine now

1 Like

One would think that would have said something lol, can confirm its the Sanctified item thats doing it…