Can't complete a seasonal journey step

My seasonal progress isn’t recognizing I have completed a step. Specifically it does not recognize I have completed step 2 even though I have received the reward for it. This is blocking me from completing the following steps.

Hi and welcome to the Forums !   :slight_smile:

I tried to view your web profile, but I couldn’t find one. Are you playing on a Console ?

On a PC, this would normally happen if you haven’t entirely completed “Chapter I”… if that is the case for you, then you need to also complete all the objectives for Chapter I before you can claim the rewards of Chapter II.

Also on the PC, you can complete the various objectives in any order you wish… but you will receive the rewards for a given “Chapter” only once the objectives of all the previous “Chapters” have been completed.

There is a web tool available to track your progress in the Journey… see here: It allows you to mark the various objectives that you have completed in the Journey


I am playing on the switch.

Remember, there are no rewards for completing Chapter I.

To earn rewards from You must also have completed
Chapter II Chapter I
Chapter III Chapter I, II
Chapter IV Chapter I, II, III
Slayer Chapter I, II, III, IV
Champion Chapter I, II, III, IV, Slayer
Destroyer Chapter I, II, III, IV, Slayer, Champion
Conqueror Chapter I, II, III, IV, Slayer, Champion, Destroyer
Guardian Chapter I, II, III, IV, Slayer, Champion, Destroyer, Conqueror

So, if you want to get the rewards from Chapter II of the Season Journey (i.e. the first Haedrig’s Gift) you must also have completed all the tasks in Chapter I. Have you done so?

1 Like

Yes, I understand. I wish I could send you screen shot. I have claimed all the rewards for chapters 1 through IV (Haedrig’s gift), but chapters III and IV are still greyed out.

Hi again,

Since you play on the Switch, I think your best bet would be to move your post to one of the console forums… either Console Discussion to ask for help or Console Bug Report to report a bug. You can move the entire topic, including all the replies, by scrolling up to the title and clicking the pencil tool at the right of the title, changing the Category from Technical Support to either Console Discussion or Console Bug Report, and accepting the change.

You can also post pictures… @Meteorblade has made a how-to guide here:

1 Like

1 Like


Here’s a preview of your picture (click on the preview to enlarge):

I’m a PC-person… hopefully, someone on the Switch can either confirm the issue or help you solve it.

Best of luck with this.

1 Like

So my issue worked itself out over the weekend. I suspect it happened when I re-met some criteria for completing a chapter. Which task was it? I don’t really know, all that matters is it worked itself out. Thanks everyone who responded.

1 Like

Many people have reported this bug on all platforms and blizzard has not responded to any of them