Armory Has Issues with Soul Shards

The armory can’t seem to tell the difference between one Soul Shard and another of the same type and level.

When switching between sets, the armory looks like it just picks any Soul Shard of the right type and level and pops it into the helm or weapon, despite not being the one that was socketed at the time of saving the build. As each of these Soul Shards have unique properties, this is obviously problematic.


I noticed this too. Had to delete my “less” preferred shards to get it to function properly. Needs to be fixed so we can run different shards for different tasks. Thanks for the post.


Yeah, thanks for the heads-up!  

I haven’t tried the PTR season theme, but sounds like the shards are being treated like legendary gems?

Yes. They are socketed into helm or weapon and give all sorts of cool effects and bonuses. They are also like legendary gems in that you can use them for augments.

Same here. Seems It works when both shards are in the bag, but not work when they are in the stash.

I encountered this same issue. I’d held onto a shard of hatred that had high Intelligence on it, for use on my WD. However, my Justice Monk kept putting it into his helm whenever I used the Armory to switch between gearsets.

Still not fixed with update, as far as I can tell.