24004 error cant join

Same issue, started today. I have rebooted / uninstalled and reinstalled the game. Nothing works…

1 Like

24004 is something I just search web for and only saw locked treads from 2020, but I didn’t see what the cause is.

Same issue. Can’t join Bounty, Rift or Greater Rift public games. Private games are fine.

Looks like they haven’t even seen this. It all started last night.

same here but we are on day 2 with no blue response yet… not to sound mean but I would be fired if something went wrong and I didnt at least write a e mail saying we know this is going on. I think they have maybe 1 dev at d3 now? Dunno but this is sad

1 Like

They have acknowledged it at least. But sheesh this is taking a while. For those who don’t know, you can still get games to work in torment 15. I’m doing gr pugs there.

deleted for a mistake I made with dates

Interesting. There are many reports of this error number across multiple locations but there is one thing in common otherwise: the majority mention the error happens only with Torment 16 games. I don’t get the error because I never play groups.

If that is the case, then this means there is something specific broken and it is, indeed, a bug and a server end issue which needs to be fixed. Not that it wouldn’t otherwise, but this is far easier to identify then.


Same error 24004. Can’t join public bounty. Rift or Greater Rift games are fine.

Started having this issue from today. Can’t join any Rift, GR, bounties public game. Getting same error code.

1 Like

This all started after they did some maints on the Chat. Every time they do maints we have some kind problem.

I can do T16 solo too it only has to do with Public games. You get the error in GR’s, Rifts and Bounties.


I guess they are cannibalizing the D3 serves to use with the D4 beta, i mean preview.

Really they still haven’t fixed this?


and here we are - does anyone know what they have said about this? Stability of the servers, login problems, now this… hmmmmm

Still having this problem after DAYS.


Well, for an alternative option at this moment, you guys can join T15 public games. It only doesn’t work on T16 public games.


I tried T13 and got the error but T15 does work!

1 Like

Yeah same issue on t16 but other difficulties work.

Error code 24004, Can’t join any public game on any difficulty. Getting the same error code. Can’t play solo there’s a crazy amount of lag.

Having the same issue. Not just Bounties but rift, GR also