PLAYSTATION 5 version NOT working AT ALL

The fact that no one on the developer/QA even started up the game with the new patch on PS5 is a little disheartening.

1 Like

It’s not impossible it’s literally what the game does, it reads and writes to the same data file so it’s 100% possible to write over the data with previously serialzed data that was not properly updated when the save and exit button is clicked. On top of that data corruption is more than real and can destroy any save file for any game. You and your friends that “did that research” have absolutely no idea how data is saved if you think it’s “impossible”. AND on top of that you’re talking to homerjnick who I have seen on the Diablo boards for years now doing his research and playing the game(s). The only impossible thing here is for you to be correct.

İs it really blizzard game??give us latest patch again!!

Omg you dropped us a sentence. Color me shocked…


Upload the oldest version? Dunno y we have to wait

1 Like

It’s still not working on PS5 can’t log in! What’s going on Blizzard? Do something about it!

RE: PS5 versions - The team has nailed down this is specific to EU users. They have rolled back the patch so users may be prompted for an update. A new one is being expedited so we should see a fix to this in the next day.


And how do you install previous version? Check for update say my game is up to date. I really dont want to download whole game again…

1 Like

It’s still not working!!! I can’t go back to the older patch version! Holy Moly! Honestly if I would do such stuff at my office… I have to look for a new job immediately!


It’s not just a EU issue, I’m in Australia and have the exact same problem, so please don’t ignore how wide spread this issue is.


Ever since last night after the latest patch I am unable to play hardcore without getting the “Your connection has been interrupted” error within 30 seconds to 5 minutes. Tested on 3 HC and 3 SC characters and it only happens on HC.

Dear God, please make a call Brian Kelly and Bobby Kotick. We can do nothing anymore.

I’m in Australia and having this issue. It is not only EU

1 Like

Australia also uses EU builds. Sorry for not clarifying there.

After downloading new patch obviously game didn’t work. I ve deleted it. Now downloaded it again and still my characters are not there. I can make a new online ones but what happened to my old characters ? And how long do I have to wait for them to return ?

You will not see your online chars, because online servers are still down since hours ago:

Do not create new online chars (especially using the same names), because maybe this could really delete your characters. Remember: Creating Online and Offline characters with the same name caused issues, which needed a patch.

For real: I am guessing that some of the “character got deleted” whiners created new characters, while the servers had problems, with the same name…

I have the same problem. Didn’t get the old patch so I’m still struggling and can’t play. Please add players8 to console bnet games!

Did this fix items from being deleted in the shared stash?

same sh*t on PS5:

its all broken after crooked patch 1.004, SECOND day (!!!)
Cant use my char and cant create new one!
Made a ticket (it`s a HELL QUEST, Seriously): EU79559470

Are you crazy? WTF? Beta is long over guys. Wake up, Neo!

1 Like

So it’s 24h ago since the new patch killed my game! I want a workaround, how I can play the game with my online chars on my PS5 until a new patch is released!! ASAP please!!

1 Like