Mouse cursor doesn't lock in fullscreen mode anymore

Same thing is happening to me on my PC. I play on 3 screens, and noticed the same issue since the update.


Same here. Very annoying when teleporting around and you end up right clicking on a different screen instead.

same issue. mouse isnt locked when in fullscreen mode. dev please fix it.

The exact same issue here, even in fullscreen the mouse goes freely to my other monitor
Tried switching it to window then back to fullscreen the issue persist

Is this why my Function key bound spells are not being cast even though they’re set?

Instead it is calling upon the windows default functions, as in mute sound, volume up and down, etc…

I’ve tried full screen and window, etc.

This is a new issue for sure.

This is now located in options as of this patch. Just a fyi.


wait, you guys see this as an issue? i have 3 monitors and i hate my mouse being locked to a single screen when im on my pc. im alwasy doing multiple things so clicking the windows key to unlock it every time is annoying.

norseman, go into your computer settings and set it do your function keys act primarily asd the function keys. you can select whether you want to hit FN to use the action on it or the function key. i dont know if you like them being set to primarily be the action they do but that will fix the issue youre having.

Tried that. Reset to legacy setup, they’re showing up in the quad access with the F1, F2, F3 all bound to the correct spell… however the game doesn’t treat it like the F keys are setup… for some reason F4 works fine, the rest don’t. It doesn’t make any sense.

well dang. i was hoping thatd be all you need. sorry bro.

Thank you!!!
Option → Gameplay → Confine mouse cursor

Yes, because it’s very easy to move the cursor out of the game window when furiously clicking on enemies etc. and then you move or don’t move to a place you did or didn’t want to go due to clicking outside the window.

theres no reason to click that far out to attack an enemy -.-

you can configure this in game play settings menu :slight_smile: choose whatever fits you

its basically bordeless window or not - that’s how other games call it

i honestly never realized thats what the borderless meant on other games. this will help me with cod lol i hate being stuck to one screen when i have 3.

1 Like

Sure there is. Also, many people who are used to RTS games which are often played in a similar perspective, tend to click around the edges of the screen when moving. I often click to cast spells at enemies at the furthest reaches of my vision. Why be close when I don’t have to be?

I always expect the mouse cursor to be locked to the window when playing games. I can always move away from it by alt-tabbing.

you can free aim your shots in their direction. you dont even need to click the enemy. just hold shift. been doing that since like 02

I use both. Sometimes I do need to pick a specific enemy out of a crowd. I’m well aware of these features, I still don’t want to accidentally click outside of the window and end up dying or not attacking.

Yep! In the Gameplay options. Is functioning as intended!

sort of. it likes to switch randomly without the setting being changed.