Corpse Explosion targeting bugged out post Patch-2.4

Has anyone else noticed that CE targeting is messed up after after 2.4?

Right clicking on a monster with CE would explode nearby corpses.

Right clicking a monster does not cast CE on nearby corpses. CE much be clicked on open ground and held down, and then while still holding down, move the cursor over a corpse.

I have found this bug to be infuriating - has Blizzard recognized this issue?


i noticed it. and it’s so annoying. hopefully it will be fixed soon.

There is a thread about it in the Bugs forum.

Yes CE is wacky…But then again I can rarely play as it lags so bad I wonder off and play something else.

I noticed this as well, I thought that was just how the skill worked. I’m glad it’s just a bug. It’s super annoying.

Yes, I noticed immediately after the patch that something was wrong. Now you need to specifically target corpses rather than the general area, which is difficult and frustrating amidst a sea of monsters and minions. Using shift + click alleviates the issue a little, but still not the the degree of convenience of the pre patch implementation.

I hope this gets corrected, since CE is basically a Summoner’s core button.