WoW Game Files Damaged + Repair loop

Hello!

I’ve been struggling with this issue for a few weeks now.

One day out of the blue, Battle.net launcher asked for permissions to make changes to this PC. I granted it thinking it was just an update for one of the recent patches, and the chaos commenced.

First it started with BLZBNTAGT00000BB8 errors, then it graduated to “Your World of Warcraft Installation is damaged” when launching the game.

Steps I have taken to resolve this issue :

  • Disable Antivirus (I don’t actually use one but I disabled Windows Defender just in case)
  • Installed Malwarebytes to check for malware - none found - uninstalled it afterwards
  • Ran the repair tool - I ended up in an endless loop of “whoops! looks like something broke”
  • Checked to see if a proxy was enabled - there was none
  • Created a secondary Admin account on my PC. Scan/Repair got stuck at 99% for over an hour before I gave up and switched back to my main profile.
  • Upgrade to the beta version of the Battle.Net launcher (this was another temporary band-aid)
  • Completely uninstalled battle.net launcher (5+ times total now, and I even found a post on another thread detailing how to clear alllllll the app data and cache. I even went so far as to delete the registry entry for Blizzard Entertainment).
  • Completely uninstalled all Blizzard games + the launcher and deleted all app data & registry files I could find
  • Performed a clean install for both the launcher and World of Warcraft not once or twice but 5 times now.
  • DNS has been changed
  • Internet connection is pristine - hard wired to my router.
  • Restarted internet before re-installing the game (again, the game works for a limited amount of time before randomly corrupting)
  • BNet launcher is installed on C drive - game is installed on a separate internal SSD. I cannot install the game onto my C drive as there simply isn’t enough space. It’s a small NVMe and WoW would place the drive beyond capacity.

Every step I have taken was a band-aid. WoW would work for approximately 4-6 hours, then like clockwork the battle.net launcher would request permission to make changes and it would proceed to cycle back into the scan/repair loop.

On my latest clean re-install of the launcher and WoW, the game worked perfectly fine for a few hours. I logged off and did other things on my PC for about 2-3 hours and when i went to launch the game again, I received the “Your World of Warcraft installation is damaged” error, to which now the launcher keeps failing the repair at about 60%.

The only variable left is my add-ons, but they are all add-ons I’ve been using for years and have never had issues with.

I don’t know what else to do here.

I am in the same situation. I am going to be forced to invoke my son.

1 Like

This is exactly what is happening to me. I just put in a ticket but I have tried fresh installs and scan/repair so many times I am going crazy. Same error text…

1 Like

Hey there,

First thing to do would be to make sure this error isn’t being caused by addons or corrupt UI. Reset the UI using the steps here. This would be a quick test, and if the error does still happen without any addons then you can rename the folders and restore your addons/settings.

Since you mentioned having WoW installed on a secondary drive, can you check the file format of that drive?

Games installed through the Battle.net desktop app only support NTFS file format drives (NTFS is the default for Windows C:)
If the secondary drive is exFAT or FAT32 format you may be able to install WoW initially on it, but the game will break after a while once files are re-written and edited. You can check the drive file format by:

Opening File Explorer in Windows and on the left side expand This PC
Right-click on the secondary drive and select Properties
Check the File System value, this is the file format.

If the drive is not NTFS you would want to back up any important files from that drive, then format the drive (which will wipe ALL data from it) and select NTFS when formatting. Support is not able to assist with reformatting drives, so if you aren’t comfortable doing this on your own you may need to get in touch with someone who is familiar with the process or check with the system manufacturer. After that is done you can reinstall WoW and you should be good.

Hi! Thank you for your response!

Unfortunately it appears that my drive is already NTFS.

I did manage to install WoW onto a storage drive, but this is not optimal and I would prefer to have it installed on the SSD that I purchased specifically for my games. I have not had an issue since switching drives other than the extremely sluggish loading screens, so that has led me to believe that the UI & addons were not the issue, as I copy/pasted WTF and Addons folder from the corrupted directory into this new installation.

So it seems like there’s an issue specific to the SSD I had originally installed it on. Do you have any other suggestions than making sure the drive is set to NTFS?

Hey again.

If you’ve narrowed it down to being an issue with that SSD it may be a good idea to check the SSD manufacturer’s support site and see if there’s any info about updates to the SSD. SSDs can have firmware updates, so make sure the firmware is up to date.

In the past there have been some issues between motherboard’s BIOS / chipset and SSDs. Since we don’t have details on your specific motherboard or SSD model I don’t know for sure if that’s possibly the issue, but make sure that your BIOS version and chipset drivers are both updated. Check with the motherboard manufacturer for that info and they usually have steps on updating the BIOS as well.

I am having this same problem, have been trying to get in the game all morning and just getting an endless loop of scan and failed updates.

1 Like

I have a MSI MEG x570 ACE motherboard with BIOS version 1.Z6
It is a pre-built machine from Origin PC.
Problematic SSD is a Samsung 870 QVO. (which I installed after receiving the PC, so Origin was not involved with the SSD)

I was able to update the chipset drivers, but not the BIOS, and am currently testing the installation on the SSD again. The SSD’s firmware is fully up to date.

Will edit this post if I experience issues again. Hoping the chipset driver update was the magic fix but I’m skeptical.

EDIT :
Well, sadly after 2 days of everything working perfectly on my SSD, the issues have returned. Played for a few hours this morning, turned off my PC, turned it back on this afternoon and my game is corrupt again :frowning:

The chipset driver update gave me the longest lasting band-aid so far, but alas, still a band-aid. I do not know how to proceed anymore :frowning:

EDIT 2 : Found the issue - I use Carbonite backup services. I had to disable the backup on that drive to allow the launcher to properly function.

I have tried all of the above, including the back up files. Still not working.

1 Like

I’d suggest making a support ticket. They ask for two files that helped the CSR find my issue.

1 Like