WoW Classic 404s on every endpoints

Hello,

I use the Game Data API to fetch item data (WoW Classic) for an internal guild tool. Lately I have started receiving 404 on every requests.

An example of a call I could make:

GET https://eu.api.blizzard.com/data/wow/item/12345?access_token=<token>&namespace=static-classic-eu&locale=en_GB

And the only response I can get from the API:

{
  "code": 404,
  "type": "BLZWEBAPI00000404",
  "detail": "Not Found"
}

Things I have tried/checked:

  • The item exists and is a quest item (Bijou’s Belongings), I already fetched that exact item in the past. Tried others item IDs without luck even with very common ones like Major Mana Potion (13444).
  • The OAuth call to retrieve the token works (using client_credentials), if I edit the token I get 401 instead. Tried using an Authorization header instead, still 404.
  • The namespace seems ok, if I edit it I get 403 instead. Also tried Battlenet-Namepace header with no more luck.
  • The locale was previously en_US (working), I changed it to en_GB after taking a look at the Region Host List on [doc, can’t include link] , but no effect at all even with bogus locale.

Thinking maybe something was wrong with that endpoint I tried to query an unrelated endpoint (/data/wow/guild-crest/index) but still the exact same response.

Everything was working ok last month and nothing changed on my end. Is there something obvious I’m missing ?


Edit: Just noticed that changing the region to US worked.

GET https://us.api.blizzard.com/data/wow/item/12345?access_token=<token>&namespace=static-classic-us&locale=en_US

Same endpoint, same token. So it appears to be a region problem !?

You request looks correct to me, it might be something with the region.

As a workaround you can ignore the locale while querying US region and it should return all available locales in a single request.