We're having difficulty retrieving content from our servers

I am receiving this error today, even though I am connected to the internet with very high speed. No matter how many times I reload, I cannot connect.

9 Likes

eu estou com a mesma dificuldade em conectar com aplicativo da Blizzard porém sem aparece “Algo Deu errado” e pensei que era da minha conexão porém minha banda larga de 1gbits e mesmo assim da erro. Se os servidores estão dando erro porque não colocam colocam aviso, compramos jogo caro para não jogar sacanagem.

I got same issue like u i had to log in to the store again even after i entered my pass and stuff

I solved this error by removing the Authenticator, logging out of Battle.net then logging back in without the Authenticator and finaly reactivaded the Authenticator.

I am happy to hear that I am not the only one having this issue. Hopefully it gets resolved soon.

Same issue for me also

Its 4:51 PM Eastern time servers still not responding.

I have been seeing this since the middle of Maintenance yesterday (Wednesday). That was the first time I was on that day, and I’m pretty sure it was working on Tuesday.

Since Wednesday 19th January 2022, (Australian time) just after reset/patch day, I’m still having the same issue almost a week later.
Is it possible our computers/OS is simply no longer supported? If this is the case, Blizzard, please let us know so we can take action. It is after all, in your best interests to keep people playing. (However, I’ve been informed Microsoft just purchased Blizzard!) Perhaps, we shouldn’t hold our breath for a quick response to this dilemma.
FYI - I had to remove the Authenticator just to keep playing.