VPN solution for "Something Broke" and/or game not installing

This is Not an issue, rather a solution to a common issue I’ve had for the past few weeks.

One day (probably after a windows update) my Battle.net client stopped working. i.e. “Oops, looks like something broke” or “Waiting for Blizzard service”. After many hours of reading troubleshooting forum posts and scouring your support page for help, nothing worked. And I tried everything short of changing ISP’s and building a new computer. I would get the service to start occasionally, but then I wouldn’t be able to install any games. It would et stuck on “Waiting…”. Other times after I restarted the app it wouldn’t start up again until I fresh installed it. It seems many other people are having the same issue I did and don’t have a solution.

After weeks of getting fed up from my friends inviting me to play COD I finally looked into it and tried setting up my own VPN, essentially changing my ISP without actually doing it. AND IT WORKED. I am currently downloading COD (all 250GB of it… Jesus) and haven’t run into a hiccup.

The reason I’m contacting is because I would have liked to see this solution on your troubleshooting guide as it would have saved me hours of headache. Just a little blurb, maybe under the “Change ISP” bullet.

Thanks for listening to my Ted Talk. I hope this helps somebody else.

VPNs are not officially supported by Blizzard, which is one of the reasons why we do not recommend it on our official support articles. We do have an alternative connection article, and these steps are one of our common go-to steps. It’s just not something that we’ll often recommend on the support pages, but it is a common step if you do reach out to our technical support team since it is a helpful step to narrowing down an issue further.

Thanks for the feedback, and hopefully this cleared up why its not on the support site specifically - it may change, but we consider this a bit of an “advanced” step. If you do ever have any issues in the future, please do not hesitate to open up a ticket or create a forum thread to reach out to us :slight_smile:

I’ve had similar issues for some time now; neither battle.net app would download/update nor would any games. This happened with multiple computers on the same network. Connecting through a VPN worked and would download correctly.

My thought was the VPN was probably working because it was bypassing settings in the router and/or ISP. Because I have friends on the same ISP able to connect - I assumed the settings were on my router. After some searching around, I decided to play around with some router settings to see if enabling/disabling something within the router would make it work.
After trying to enable/disable multiple setting (including the firewall, QoS, prioritzation, DMZ, etc) - nothing worked.

I then ran across the setting for in router ad-blocking (Privoxy). Disabling Privoxy fixed the connection issues for me.

Not sure if your router has similar - but maybe something to check?