Unable to re-install battle.net launcher BLZBNTAGT000008FC

Yesterday I decided to re-install the battle.net launcher in an attempt to fix an issue I was having with slow downloads. Unfortunately, this has sent me on a massive goose chase to try install bnet at all. After contacting support with little help, I’ve tried every single solution I could possibly come across.

Whenever I run Battle.net-Setup.exe, it will do one of two things.

  1. It gives me error code BLZBNTAGT000008FC and requires that I close the app, along with a link containing a set of instructions on how to fix the error. This list includes restarting the computer, closing all apps outside of windows processes, temporarily disabling/uninstalling security programs, and resetting the WMI repository. All of which I have done to no avail, I still get the same error code.
  2. Sometimes when I launch the installer, it will allow me to start installing, only to bottleneck and eventually stop at 89%, where it stays indefinitely. To remedy, I have tried clearing my cache and all previous app data/instillations, flushing my DNS, temporarily disabling windows firewalls, running as administrator, double checking I don’t have a proxy enabled, and repeating all of these steps over and over and over and over to no avail.

I just want to play the Overwatch 2 beta so I can prepare with my team for the Contenders Summer Series, but I can’t even install the launcher again, let alone launch the game. Please help

3 Likes

litterally the same thing happened to me. why doesnt blizzard have a real support system. im so mad i paid money for this beta

I’m also having the same problem I’m even giving up on playing this cod season

1 Like

same happend to me and i don’t know how to fix

Howdy Asher,

As was explained in the support ticket, the problem you are experiencing is due to an issue with the Windows Management Instrumentation service. For some reason, this service is disabled or not functioning correctly. This prevents the Blizzard app from working, so you need to get this service working again. If the steps we provided in the support ticket (also listed here) don’t help, then this points to a deeper problem with the operating system that is beyond our ability to fix. You would need to contact Microsoft directly or a local PC tech who can investigate the problem. Alternatively, you could consider resetting or full reinstall of Windows. If you choose to go this route though, please make sure you have all important files backed up on another harddrive or location so they aren’t lost.

As for everyone else, it’s difficult to determine what problem is causing the error for each of you individually. You can try the basic troubleshooting steps here which may help, otherwise if you wish to contact support directly, I would recommend creating a support ticket with your MSInfo so we can go through some advanced troubleshooting.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.