Unable to open support ticket

I receive an error every time I try to open a ticket. I have tried many different ways and always the same error.

I have screenshots on imgur, but despite having a hyperlink option while creating this post it tells me I am unable to include links.

The error text is as follows:
We were unable to submit your ticket. Please check that all fields have been correctly filled out.

All fields are filled out.


Once you paste the URL, use the “Preformatted Text” markdown on it (the </> button in the toolbar).

Example: www.google.com

However, are you still having issues? There were problems with the support site yesterday that have since been resolved.

I can’t contact the support either. I’m trying to figure things out for my toon in WoW but I can’t hit the submit button. What ever happened to the here’s the email. We will get back to you. When I ask questions about WoW it takes me over too here’s a fix for overwatch. Not what I’m trying to do lol

1 Like

almost as much fun and luck as I am having Was able to open a ticket BUT here it is 25 hrs after it was “opened” and not even so much as a too bad so sad reply AWESOME customer service NOT

I cannot open a ticket from a MAC while attaching a support file that is 5MB. The site times out and errors. Tried chrome and safari.

Bump. Was this ever resolved? I am having same issue. Blizzard needs to address.

1 Like

I have the same problem.

seems like blizzard doesnt like people