Unable to download, OS unsupported...But I have min reqs

I have minimum requirements for WoW classic on my mac. It says I need 10.13…which I have. And supports says that it should work and to report it as a bug. So I am…any help?

Please use the Mac forum for this inquiry