Stuck as Adventurer (Shadows Quest)

Same issue, Has anyone already solved it?

Needs 2 be fixed for me 2.
Guide does not work for me… shame.
Hey Blizz jusz set the lottery on endless loop so it s obly a matter of time for most players or let us reset this ***** quest

this worked for me. try it guys

I was also stuck on this for several days and was able to solve it today. For the magnifying glass trick to work you have to leave your clan/warband.

1 Like

Blizz I am in for 5 bucks to fix it as leader of a small clan

Unbelievably awful that no one has even responded with acknowledgement of the issue. This needs to be fixed, especially for clan leaders who paid actual money for the platinum necessary to start their clan. At least say SOMETHING

I’m stuck too, Blizzard please fix this!!

Same here. I dropped the 2 signets into the clan, even though I “thought” I had given one to Mr. Mysterio first. It’s like it didn’t take or I was given a pop-up window that redirected me to the clan donation. I don’t recall exactly what happened, but it all happened whilst standing right in front of the Mysterious NPC.
Being clan leader doesn’t allow me the luxury to leave and rejoin clan to resolve, which btw, many of you can do to resolve the issue. Leave the clan, start the quest again. You’ll have to go thru the “Mettle” questline again to get the signets, but at least you’ll get them back. I’m stuck in perpetual Hell 1 until they find a way to resolve it. Allowing me to delete and re-accept the quest seems to me should work, but I can’t do that either.

1 Like

21 Days this Topic is up and Blizzard does nothing about it Stuck as Clan Leader Blizzard Spits on his Customers i will recharge all my Money i spent … f*** y** !

I have been playing Blizzards games for a very long time, solve this issue, or i will stop playing games from you anymore

Thanks thats the solution!

Also having the same issue. I’ve just resigned myself to the fact that I won’t be able to join until it all resets again.

A follow-up on a possible fix for some.
CLAN LEADERS in particular, if you have the Shadows quest in your log, but threw your signets into the clan’s dark clan pile. I can confirm, having done this a second time, there is a pop-up/redirect that opens the dialogue to add them to the clan pile just as you are trying to turn in the one to the NPC. THAT redirect needs to be killed!

Level an alt to the level where clans open up for them, send a request to join your clan from that character. Switch over to your clan leader character, accept the request and then make that freshly rolled character the clan leader. Leave the clan on your old leader. Go back through and try the quest. If you see a grey JOIN box in the quest dialogue, click it anyway. You should bet thrown back to running the Mettle quests to get your 2 signets.


However, I don’t think I was able to rejoin my clan as a shadow. I ended making a new shadow clan, but still have clan leadership in the old clan via that alt I leveled up.

The fix worked for me as well

This topic was automatically closed after 30 days. New replies are no longer allowed.