Stuck as Adventurer (Shadows Quest)

:unamused: no fixed nothing. I have the same problem…

Magnifying glass trick worked for me.
Mobile.
Its on a right side of the quest.
Just tap multiple times on “Submit” and you will get dialog box,press ok and it will reset quest.

1 Like

Im getting the trial print error messgae too. It says to wait until tomorrow which is something i can do but i would have liked to avoid this whole mess in the first place. I loved this game until the first big bug i ran into and while im still trying to love it, stuff like this makes it difficult.

have same problem, FIX PLS

I’m also stuck on this quest. I’ve been shadow last season and had no problem. Now I can’t do anything…

Same Issue here, ther is also a second post

Same issue on my end. Joined last season without issues. Did the lottery, received the signets, but now I cannot join.

thank you a lot! This works!

Just found it. I still has the problem

I am having the same issue. Donated both signets and now I’m in limbo. I followed some of the suggestions above and was able to quit the clan. Still can’t enter the lottery.

Didn’t work for me, still stuk

Same issue, Has anyone already solved it?

Needs 2 be fixed for me 2.
Guide does not work for me… shame.
Hey Blizz jusz set the lottery on endless loop so it s obly a matter of time for most players or let us reset this ***** quest

this worked for me. try it guys

I was also stuck on this for several days and was able to solve it today. For the magnifying glass trick to work you have to leave your clan/warband.

1 Like

Blizz I am in for 5 bucks to fix it as leader of a small clan

Unbelievably awful that no one has even responded with acknowledgement of the issue. This needs to be fixed, especially for clan leaders who paid actual money for the platinum necessary to start their clan. At least say SOMETHING

I’m stuck too, Blizzard please fix this!!

Same here. I dropped the 2 signets into the clan, even though I “thought” I had given one to Mr. Mysterio first. It’s like it didn’t take or I was given a pop-up window that redirected me to the clan donation. I don’t recall exactly what happened, but it all happened whilst standing right in front of the Mysterious NPC.
Being clan leader doesn’t allow me the luxury to leave and rejoin clan to resolve, which btw, many of you can do to resolve the issue. Leave the clan, start the quest again. You’ll have to go thru the “Mettle” questline again to get the signets, but at least you’ll get them back. I’m stuck in perpetual Hell 1 until they find a way to resolve it. Allowing me to delete and re-accept the quest seems to me should work, but I can’t do that either.

1 Like

21 Days this Topic is up and Blizzard does nothing about it Stuck as Clan Leader Blizzard Spits on his Customers i will recharge all my Money i spent … f*** y** !