No Cinematics No Splash screens Digital D2 Classic

Hi i am not getting cinematics/splash screens in my D2 Classic version. I did not get the retail box, I got mine here the digital key only. Do I need to download some other files?

You need to not play -windowed

i’m not playing in windowed mode.

EDIT

Hi, can some Blizzard rep help please. I searched on the net, the last time a lot of ppl had this problem was in 2017. That thread was unresolved. There’s something wrong with the way you packed the digital install?

  • i am using hd radeon Whistler XT, true 4-core i7, 16gb of viper, raiding on 1tb of patriot ssd.

  • i am using some form of Catalyst. NO, i CANNOT update to latest drivers. i am running on a laptop and i have to ONLY use THESE specific oem manufacturer’s display drivers. have tried all else, will not work. no further updates. but i can run fallout 4, skyrim se, dragon age inquisition. we are talking about Diablo 2 right?

  • No i’m not running windowed mode. i didn’t even know how to switch to windowed mode. i learnt now, u have to add a -w to switch the exe. i did not do that. the game was missing cinematics right after install, by default it is not in windows mode. And yes, my monitor resolution is set to native. but i also tried other sizes. no difference. it’s like it’s playing i can hear sounds, but screen is BLACK. Some ppl get to see a blue blizzard logo, i don’t even see that. if i remember correctly years ago, when u start D2 Classic you get a fiery golden 'Blizzard Entertainment Presents…" in the center of the screen right? i don’t get that either. after i enter the main menu, i try to view the cinematic by the button on the menu, select Act I… and the same problem. Sound but screen BLACK.

  • this digital installer you got us to download, has no option like the old retail CD’s. there’s no FULL or PARTIAL installations whatever. remember when we had the cinematics disc? anyway, i further tested by downloading a cinematics disc iso from the net, and replaced d2video.mpq and PLAYD2.MPQ in my d2 directory. no difference. something is causing the cinematics to not render video only audio