MW error code after reinstall BLZBNTBNA00000012

I have uninstalled Battlenet along with both Modern Warfare games due to non connectivity to the servers. When i reinstalled MW i get an error code that an error has occured while launching the game. I have tried both remedies of checking for updates and scanning to fix the game. Nothing has happen to show me that it has worked. On the forum it asks to make sure the file isnt in a temp folder (which it is not). After that it says to come here and here i am. Please help. Not sure what else to do besides uninstall and redownload again.

8 Likes

Bump. Have you had any resolution on this? I am having the same issue. Thanks for your help!

2 Likes

how do we fix this problem?

I am having the same issue. I tried uninstalling, reinstalling, and scanning still no luck. It will not let me open the app at all. Anyone having any luck in fixing this?

2 Likes

for me the same as well like this

a me era gia successo e avevo risolto impostando l’esegui come admin, ora lo rifà e non riesco a risolvere, AIUTO!!!

i having issue that after a small update around 400mb my game start to stutter and drops fps way lower. i already tried reinstall this game and edit some config files still no solved this issue god damn it

Hey all,

BLZBNTBNA00000012 means either something is blocking the Desktop Application’s access to the specific game client or there is corruption in the data for the Game Client or App.

The first step is to temporarily disable any AV security software and retest. If that does not help, then temporarily uninstall, restart the system and retest. If the issue persists, go ahead and reinstall your security software and continue on:

  1. Launch the Blizzard Desktop Application and select the tab for the game you need to ensure is uninstalled.
  2. Is there a settings button (gear symbol) next to the install/update/play button for the game? If yes, click it, then choose show in explorer.
  3. If there is no gear symbol, right click Windows Start, choose open explorer and navigate to where you would have originally installed the game. (typically under Program Files(x86))
  4. If the uninstall option is available use it and then manually delete any remaining folder/files for the game in file explorer. If there is no uninstall option, then manually delete the game folder if it exists.
  5. Leave the explorer window open but exit the Battle.net Desktop Application.
  6. In File Explorer, navigate to the folder where the desktop application would normally be installed. Delete that folder if it exists (usually program files x86)
  7. Type the following into the address bar (not the search bar): %APPDATA% and press enter.
  8. Delete the Bnet and blizzard folders inside the appdata folder if they exist.
  9. Repeat steps 3 and 4 with %PROGRAMDATA% %LOCALAPPDATA% and %TEMP%
  10. Empty the recycle bin.
  11. Create a new administrator account: Creating a New Administrator Account - Blizzard Support
  12. Once the account is created, shut down the computer, wait 60 seconds, restart, log into the new profile.
  13. Now reinstall the app to the C: Drive.
  14. Reinstall the game client.

It’s a bit extreme but it will typically solve permission/access errors like this.