MW 2 Beta crash on start

Yeah that didn’t work for me :frowning:


I have updated all the drivers and even run it as administrator, delete the game and reinstall it and continue with the same error when running it which is error 0x00001338 (10509) N


Same i tried to uninstall the game mutiple times and reinstalling but nothing worked


2 times reinstall the game, update latest nvidia driver, open for administrator… everything.
still cant open the game.


I’ve tried everything, can’t get past the Activision logo on start-up, Activision has no support available, Call the cops we just got robbed

The download went fine but is not letting me do the update. Says I need to allow permissions which I have done multiple times. Any help on how to get this thing updated. Already have the administrator checked off in properties.

same exact issue here as well

Same problem here, tried to fix it every way possible.

Bro same. if someone figures it out. help a brother out.

What I just did was update my windows and it works now so type in drivers on search and itll say up check for updates and it might have an update and it worked for me.

it doesnt worked for me

No me funciona desde ayer ni hoy me he gastado 100 euros en un juego, blizard queremos solucion ya

same bruh, where is support? has anyone fixed it?

same here i dont know whats poppin with Blizzard. Pay more then 100 bucks to play the Beta and i cant even start it, these Dudes aint serious.

same here, found any working fix?


Get the game on steam and play that version to see if it works (worked for me). If It works, refund the game on If it doesn’t work refund it on steam and wait for a fix.

I hope this helps!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.