Mouse Lock suddenly enabled on PC in Fullscreen

30 minutes ago my mouse wasn’t locked to DI in Fullscreen, now it suddenly is. It’s locked to DI even when DI isn’t in the foreground. I can’t even use alt+tab to get the mouse off of DI, only the windows key will let me out, and sometimes not even then. DI’s version hasn’t changed between when it was off and when it was on.

Is there any way to revert this? It’s very frustrating. “Full Screen (Windowed)” isn’t actually full screen, so that has its own drawbacks, but if that’s all I have to work with right now, I’ll use that in the mean time. Mouse lock should really be an option in the game somewhere though.

+1 This issue just started to happen to me as well. Blizzard please fix this

same for me. meaning that windowed fullscreen and windowed doesn’t help at all.

this happens on the update to 1.5.3


Mouse Cursor Improvements

  • Mouse cursor design has been simplified to increase visibility in visually complex scenarios.
  • Mouse Cursor size has been increased by 25%.
  • The Mouse Cursor will no longer alternate when hovering over enemies."

So, no fixes on this issue?? Omg!

Is this working as intended? Pls no.

it can be by design in FULL SCREEN but the windowed fullscreen and the windowed options are simply the same and it doesn’t work as intended

This topic was automatically closed after 30 days. New replies are no longer allowed.