Mature language filter

“Preface: It makes it a bit harder to report this potential bug when the words are banned in the forum, so I had to put in spaces.”

A friend and I were screwing around in the chat and he wrote the word “he-tero” (without the line) to me. However, I could not see it since the mature language filter ate it. That made both of us rather curious. So he tried typing “he-terosexual” (without the line) as well, and that was grabbed by the mature language filter. He then tried writing “homosexual” and that was not grabbed by the filter. The only two combinations we could get the filter to catch was “he-tero” on its own and “he-terosexual” as one word.

We then continued to do a short test inside the chat in World of Warcraft, where we tried using the same words as above in whispers and in guild chat. But it seems like in-game there is no filter for “he-tero” or “he-terosexual”. All of this was quite perplexing to us since we could not figure out why a word that just means different gets snatched by the filter. Therefore, I contacted a GM and I got advised to report it as a bug, which is why I am here.

Our best guess is that there are separate filters for chat and for World of Warcraft chat and that somehow “he-tero” and “he-terosexual” snuck into the filter list and were never part of the World of Warcraft filter.