[Main Thread] Schannel ErrorTLS connection (Oct 2023)

Starting around noon today me event viewer has been looping 2 errors at a time when Battlenet is open about every 5 minutes. I have uninstalled and reinstalled battlenet, checked all updates for Bnet and Windows, allowed bnet in firewall etc. While I don’t see it currently affecting anything, its annoying to look in even viewer and seeing around 100 errors without a cause. I have ensured that all Digicerts are valid, latest was Oct 18th.

The certificate received from the remote server has either expired or is not yet valid. The TLS connection request has failed. The attached data contains the server certificate.
The SSPI client process is Battle.net (PID: ####


Same here. Lots of Schannel errors in Event Viewer. When I look at details it’s related with Blizzcon server/site. Not sure, I’m not an expert. No errors when I close the App.

“The certificate received from the remote server has expired or is not yet valid. The TLS connection request failed. The attached data includes the server certificate”.

Yeap same here, doubt its on our end since a cert being issued from blizzard app is not valid or has expired is something they might need to look into.
My guess at least…

Sequence Interval: 5 mins

It’s been the same way for me.

I left my PC idle for some hours, when I came back the taskbar froze for a few seconds. When I checked the event viewer to see if something happened, I had a huge wall of the Schannel error with the 36881 event ID.

Im getting a lot of errors like this too.

https:// i.imgur. com/80V9xh9.png


Please learn to post links without using spaces… hunting spaces in a link is difficult.

Instead of putting spaces, highlight your entire link, and click on the </> button on the formatting bar (button #6). This will transform the link into preformatted text and be permitted by the forum software… like this: https://i.imgur.com/80V9xh9.png

Embedding the screenshot for you:

I too have the same errors… started on 2023-10-30 at 13:27 EDT.


Well you learn something new every day. Thanks.

1 Like

Looks like the app is doing requests to api-cache dot blizzcon dot com which has an expired certificate when requested through HTTPS.

1 Like

same for me… Diablo4 hangs and windows log is full of errors like this…

“The certificate received from the remote server has either expired or is not yet valid. The TLS connection request has failed. The attached data contains the server certificate.
The SSPI client process is Battle.net (PID: 22096).”

I have the same problem , my logs is full of this error

same here, any fix yet?

Hey there everyone,

I just wanted to let you all know that I have sent this up for investigation. I do not have an eta on resolution and the only work around atm is to set the desktop application to exit when launching a game. Or closing it out when not playing. Any potential solutions/workaround I get, will be posted in this thread so keep an eye on this thread for that.

Edit: We are looking to get some log information for the Desktop Application.

Please follow the steps listed at the link below to obtain some battle.net log information for us:

Once the .zip file is created, please email it to techinfo@blizzard.com

Please include the title of this forum post in the subject. Also put something in the body of the email to ensure it doesn’t get rejected.

1 Like

this error is causing hard freeze to my pc which I never experienced!!! what are you doing Blizzard? Breaking customer’s pc now??

hey, Im not going to download any other app when your bnet app is causing errors on my PC, I deleted all now. Its a bad joke, just give me access via steam that I could play again if bnet is broken :<

Email sent as requested. Some people here are so entitled. They demand quick fix, but when there is an opportunity to help the company to find the issue and fix it faster, they do not want to help. It took like five minutes in total to get that file and send an email.

Edit: You message for techinfoatblizzarddotcom from 2023/10/31 could not be delivered.
It’s attached below. Reason: 5.0.0 smtp; 550 5.7.0 Message Size Violation

Permanent Failure - Other or Undefined Status

The .zip file is 5156 kB … probably that is causing the issue with sending the email.

1 Like

Hi guys , same problem here.
But I think the problem is not on your side as the message says a problem with TLS connection.
waiting for a fix (actually I close bnet launcher when I launch a game like suggest Kershew)

I tried to provide the info but i got an error email saying:

Your message couldn’t be delivered to techinfo@blizzard.com because it exceeds the size limit. Try reducing the message size and then resending it.

File size is 1.7MB.

Tried to upload it on google drive but im not allowed to post links.

E 2023-10-31 12:58:47.496945 [LiveStreamingAPI] {Main} Failure response, CURL error: 'Send failure: Connection was aborted' http status code: 0
I 2023-10-31 12:58:47.496972 [LiveStreamingAPI] {Main} Retrying request
E 2023-10-31 12:58:47.526876 [LiveStreamingAPI] {Main} Failure response, CURL error: 'schannel: next InitializeSecurityContext failed: SEC_E_CERT_EXPIRED (0x80090328) - The received certificate has expired.' http status code: 0
E 2023-10-31 12:58:47.526901 [LiveStreamingAPI] {Main} Retry threshold exceeded
E 2023-10-31 12:58:47.526906 [LiveStreamingAPI] {Main} Failed to check if BlizzCon is live. Error=5400

Since the e-mail stuff isn’t working, these are the relevant log entries. It is sending requests to api-cache dot blizzcon dot com (can’t post links) which has an expired certificate that needs renewing.


Hey everyone,

Just wanted to thank everyone who sent in the log files I got those attached to the case and the devs are already working on a solution that is in testing now.

Can we get everyone to try two more times. The first you will likely get the error, the second should be back to normal. Feel free to reply with your results.

Email got rejected 3 times in a roll. Tried changing the text but no luck.