[Main Thread] "Failed - Network Error" for Diablo II & LoD Set-up Files

bruh WHAT lmaoooo that is so gay. So because I do chaos/Baal runs, I get a temp ban

Pretty much, doesn’t make sense to me either. They don’t care enough to do something about it

That is the most insane reason for a ban I’ve heard. Literally grinded to 86 for what :woozy_face::woozy_face::woozy_face: and it’s a 2 week ban I assume?

there’s no way to know really can be 1hr,24hr,72hr or 2 weeks I think.

That is absolute cheeks omg lol. Thanks tho man!

Replaced the links to remove the www. seems that some of those links were causing issues like “site not found” due to the issue. The site may still give the site not found error, but it should still prompt the installation. If you experience any issues with the links please let us know!

This thread is intended to track issues with the Diablo II set-up file installation. If you are experiencing this issue, please refer to the post above to grab a different region’s link for your preferred language.

If Diablo II is already installed, this thread is not the correct one to report on. Please refer to a more relevant or create a new thread.

If you are experiencing issues with the Blizzard Desktop Application’s set-up file, please refer to this thread.

Hey mate, sorry to hear about your problems!!

I have similar issues, they are not replying to me and my questions.
I have server problems - checking versions more than 24 hours already.

Blizzard is supposed to motivate and support the people during that crisis period, but instead of that they are making bans/restrictions and even not helping to the people…

Its a shame i trusted them so many years…

Bro, you’re a legend. Cheers.

@Blizzard … Honestly, never expected any better so. Thanks for nothing?

@Blizzard - should not have had to seek out player workarounds for your failure!

Every single classic game will not download, they error out at 90%, leaving partial files on my computer.
I’ve tried, both diablo 2 versions, both wc3 versions, and starcraft. Everything errors and nothing will get past 90% before cancelling from the server-side and stopping the download.
Is there a mirror for these setups, or are the servers that broken on blizz’s end?

1 Like

Alguna solución para este tema?

I’m also having this issue trying to download Diablo II and LoD. Tried all available regions for {REPLACE_LOCALE}=enUS and {REPLACE_OS}=win, not success. Here is the suggested traceroute result (will last a week): E7Rd3ym8

Thank you for the connection test, macdowell. There’s quite a bit of loss throughout this test, and the latency is spiking quite a bit after the home network.

Could you try the following steps? Click here.
  1. Try an alternative connection.
  2. If wireless, try a wired connection.
  3. Reset the home network devices.
  4. Try a public DNS service such as Google DNS or Cloudflare. By default, the system uses the provider’s DNS.
  5. Let’s reset your computer’s TCP/IP and Winsock. This can resolve basic issues with browsing or connection issues.
    1. Right click on your Windows Start Menu, and select “Command Prompt (Admin)” or just search for Command Prompt and right click, run as administrator.
    2. Now type in or copy and paste, “netsh int ip reset” Press Enter.
    3. Then do the same for “netsh winsock reset”
      Once it’s complete, you’ll need to restart the computer to complete the reset.

If it persists, let’s make a separate thread with a WinMTR test or feel free to reach out to our Technical Support team so that we can work with you on the connection issues to the patch servers. We’ve seen issues with the general area that might be contributing to the throttling or mitigation resulting in the installation to fail.

For everyone else, we’re continuing to look into the Failed - Network Error and partial installation issue for the Blizzard Application and our classic games. If anyone else is experiencing this issue with Diablo II or LOD set-up, please refer to the post above. If the links do not work, please let us know!

Came here for the same reasons as everyone else, but none of the altered links are working either. I tried eu, kr, and tw (always with enUS and win) but can’t download the base game nor expansion.

Yep. Links still aren’t working… nice to know we paid for these games YEARS ago and can’t play them when we want to. Thanks Blizzard!

I tried multiple different mixes of region locale and nothing is working. I got the LoD to download but that is pointless without the main game.

Hey all,

Please continue using the links here. We cannot guarantee that these will always work due to network congestion since the COVID-19 quarantines, so you may need to try links from different locales to see if it fixes your issue.

A post was split to a new topic: DreamZ - Diablo 2 Installation Failure

Tried everything mentioned in all of these threads. What the hell is wrong with this?? There’s literally no fix around right now. Have a beast of a rig and internet speeds and I cannot download a game from 20 years ago…

Funciona ,si no lo descarga o si descarga super lento esta es tu solucion.