[Main Thread] Can't launch the Battle.net App - DLL error

I’m on my 3rd reinstall of the day…

It’s BUSTED, it updates itself in the background and forces me to restart the app before playing anything which then borks itself.

5 Likes

I have the same problem. Would be nice if we got a heads-up for eta of a fix!

2 Likes

just came here to check what’s going on, not gonna bother with it. i’m gonna use wow.exe, directly, until someone knowledgeable gets dragged in to fix this. this is second time, recently, something like this happens, they clearly have some new guys on it.

Same here. I have to unninstall and install every time to play.

It worked yesterday, but today when I turned on the computer, the error came back.

Hey everyone,

I saw many reports here and elsewhere about this .dll missing error. The developers have been alerted and are looking into fixes.

In the mean time, it sounds like reinstalling the Battle.net application may fix it. I found some more information suggesting that extra folders may be in the same location that Battle.net is installed to. If the reinstall doesn’t help, please check that location for a Battle.net 13360 and Battle.net.beta.13361 folder. If they’re there, delete them and then run the Battle.net launcher again. If anyone does this, please follow up here with results so we can forward them along to the developers.

5 Likes

mine had 13360 and 13365.
deleted 13360 and tried loading up,
same problem.
deleted 13365, tried loading up,
worked . went right on in to play.
i have closed and restarted several times to make sure
works every time. the folder will have a ( helper dll listed in it. }
i think this is causing the issue.

2 Likes

Having same issue, reinstalling works, but have to do it every time I close bnet launcher.

1 Like

Same. Reinstalling worked then problem returned.

1 Like

I dont even know whats going on with mine, just wont open

1 Like

i done reinstalled about 5 times and nothing is working

1 Like

deleting the folders didn’t help, I don’t want to reinstall bnet every time I open it. Couldn’t they just do a rollback until they figure out what they screwed up?

This could be a way out… if everyone was impacted by this issue.

Which is not the case.

I think it is best if they try to figure out why it didn’t work on the few instead.

Yesterday, i did a reinstall and it worked after that but today… i tried 4 times and still it doesnt work…

1 Like

I am still having the same issue Blizzard please fix your DLL with a new update stop telling us reinstall stop being lazy and fix it

3 Likes

Also broken here.

Windows 10 x64 Home
Version 21H2 (OS Build 19044.1586)

I’ve run the bnet installer (without uninstalling beforehand) and that’s let me login again, but I’m avoiding restarting my PC until a fix is confirmed.

I deleted the 13360 folder without reinstalling B_net, and it launches fine.

5 Likes

Hi,

Two players on Europe French forum say that they deleted the Battle.Net.13360 folder and that everything is now working. See here and here.

I hope this helps.

2 Likes

Hey again everyone,

Just got word that the cause of this should be addressed. It does seem that it may not be a retroactive fix in that if there is bad files are remaining, they will need to be manually deleted. The idea is what was shared earlier.

Using file explorer, go to where the Battle.net application is installed. Typically thats: C:\Program Files (x86)\Battle.net

Look for any Battle.net.##### folders here. The ##### is probably going to be 13360 in this case. Just delete those folders and then restart the Battle.net application. A reinstall should not be needed.

I’ll keep this thread open for now to monitor if this persists for anyone. Thanks Boubou and everyone else for the updates and patience while this was sorted out.

6 Likes

Had the 13360 folder in my install location, deleted it and bnet launches fine now, including after a system restart.

3 Likes