[Main Thread] Agent Went To Sleep BLZBNTBNA00000005

I just had the same issue and tried everything on the list blizz provide on
us.battle.net/ support/en/article/16531
But what fixed the issue was of course not on the list.
I removed the Battle.net folder from the AppData folder which you can acces by doing windows-R and type C:/ProgramData
Quit battle.net app, Find your Battle.net folder, delete it, and launch the battle.net app.

I hope it will help !


Had the same issue. Restarting didn’t help, running as administrator didn’t help, and I sure as hell wasn’t going to disable my security programs. So a week goes by and I try the solution Kharga gave above (though I did have to delete both the Battle.net and the Blizzard Entertainment folders).

And it worked. Took less than 2 minutes to implement, then things ran smoothly. And even if it comes back again (as I have heard it can), I can just do it again, and again, till Blizz fixes this.

So thank you Kharga, for a nice, simple, WORKING solution.

Since the morning of 9/16 I have been unable to update or install any games in the Battle.net launcher. The install prompt will eventually time out with a BLZBNTBNA00000005, …6, or similar error.

I’ve reinstalled Battle.net many times, deleted ProgramData folders for Battle.net and Blizzard, disabled firewall, restarted system, etc.

Issues I’ve seen in the logs posted below.

From the Battle.net log in AppData:

I 2022-09-16 23:46:18.196293 [TactProduct] {Agent} Fetching remote version info for agent
I 2022-09-16 23:46:18.211970 [DIAG_Downloader] {Agent} adding network address for server http://us.patch.battle.net:1119
I 2022-09-16 23:46:18.331411 [Agent] {Agent} Agent up to date as: 8009
D 2022-09-16 23:46:22.731374 [Agent] {Agent} Agent (launch= 16) ran for 4sec(s) since last restart.
D 2022-09-16 23:46:26.809557 [Agent] {Agent} Agent (launch= 17) ran for 4sec(s) since last restart.
D 2022-09-16 23:46:31.355092 [Agent] {Agent} Agent (launch= 18) ran for 4sec(s) since last restart.
D 2022-09-16 23:46:35.729271 [Agent] {Agent} Agent (launch= 19) ran for 4sec(s) since last restart.
D 2022-09-16 23:46:40.292325 [Agent] {Agent} Agent (launch= 20) ran for 4sec(s) since last restart.
E 2022-09-16 23:46:40.292406 [Agent] {Agent} Agent restart limit exceeded
I 2022-09-16 23:46:40.436968 [TactProduct] {Agent} Fetching remote version info for agent
I 2022-09-16 23:46:40.459187 [DIAG_Downloader] {Agent} adding network address for server http://us.patch.battle.net:1119
I 2022-09-16 23:46:40.581124 [Agent] {Agent} Agent up to date as: 8009
D 2022-09-16 23:46:44.945499 [Agent] {Agent} Agent (launch= 21) ran for 4sec(s) since last restart.

From the Agent logs in ProgramData:

[I 2022-09-17 16:06:32.0993] Network Connection Response to http://us.patch.battle.net:1119/agent - CURL error: 0, Status Code: 404

From the Errors log in ProgramData:

An application encountered a critical error:
Program:	C:/ProgramData/Battle.net/Agent/Agent.8009/Agent.exe
Exception:	0xc0000005 (ACCESS_VIOLATION) at 0023:0xf67

The instruction at "0x00000F67" referenced memory at "0x00000F67".
The memory could not be executed.

<BlizzardError.Platform>All PC

0xc0000005 (ACCESS_VIOLATION) at 0023:0xf67

Thread 0x00000330

Showing I do have connection to the patch server:

$ nc -z -v 1119 1119 (bnetgame) open
$ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=50 time=52.7 ms
64 bytes from icmp_seq=2 ttl=50 time=51.8 ms
64 bytes from icmp_seq=3 ttl=50 time=59.4 ms
64 bytes from icmp_seq=4 ttl=50 time=53.8 ms
--- ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3005ms
rtt min/avg/max/mdev = 51.787/54.427/59.377/2.949 ms

This may be related to other reports indicating a potential issue with the newest version of the update agent in which case it should be posted in the bug report forums. prior to that however, see if the following helps at all:

Try doing an extended power cycle on your system. Turn off all devices including the modem. Wait 30 minutes, turn on the modem, wait 5 minutes, turn on any network devices, wait 2 minutes, turn on your computer and try the game.

You can try switching your DNS settings to use a free public DNS servers instead of your ISPs Servers:

We do not have individual steps for specific modems or routers so if you need assistance accessing or updating the devices, contact the device maker/provider.

From here we need to manually clear the Battlenet Desktop Application and all supporting data from the system. This will not remove existing game clients.

  1. Open file explorer/file manager (Right Click Windows Start)
  2. Navigate to the folder where the desktop application would normally be installed. Delete that folder if it exists (usually program files x86)
  3. Type the following into the address bar (not the search bar): %APPDATA% and press enter.
  4. Delete the Bnet and blizzard folders inside the appdata folder if they exist.
  5. Repeat steps 3 and 4 with %PROGRAMDATA% %LOCALAPPDATA% and %TEMP%
  6. Empty the recycle bin.
  7. Now reinstall the app to the C: Drive.

Make sure to test once, restart and test again as some reports indicate the issue returns after working normally the first time after doing these steps.


same here on steam Deck (Desktop Mode).

i used Steam Proton to play D3, runs rock solid, did HC season 26 journy solo without any issues. Also stared season 27. A few days ago, there was an scheduled downtime during prime time (20.00-21:00 CEST). i haven’t played until yesterday, since i’m not able to login anymore, i always get [BLZBNTBNA00000005].

So i decide to throw the bottle (wine-prefix) away and create a new one from scratch. Now i get BLZBNTAGT000008FC.

Lutris/Linux user here. If you can copy your Bnet install and game install from a Windows machine into the proper locations on a fresh prefix (that meets the requirements, basically run the installer until it gets to the bnet client install and cancel), you can launch Battlenet to a point where the window itself freezes. From there you can right click on the icon in the systray and click on the game (assuming you have it installed in the same location on the Windows machine).

Starting up Bnet after that is a rinse and repeat process. Before the Window can detect the “updates”, right click and launch your game.

I got the same issue as the op. I have had 1 success yesterday with reinstalling by doing these steps and now it sadly stopped working. Following the steps again does not work.

I have the same exact issue.

I’m going to try that now. I thought Battlenet would fix what they did and not depend on others to fix their mess.


That didn’t help fix the problem. I don’t think there is anything we can do it’s all their side. This problem goes back almost 3 years and they still don’t have a fix. It’s a bug with the update agent until they admit they have a bug and take steps to fix it we are all sol.


I remember first experiencing the infinite update loop in early 2021.

However, I accidentally killed my prefix and can’t get the battlenet installer to fail anymore. It installs 100% then goes back to 0% and hangs, so Lutris can’t complete it’s script. I may have to copy and paste folders and winetricks manually.

I tried your suggest solution and many solution from google searching, but still can not solve this problem.

1 Like

Same problem here. I cant install games

Same issue for D2R on Steam Deck! Please fix this!

Having the same exact issue on steam deck! I got error code BLZBNTAGT000008FC one of the times ive gotten this code as well. Man wow was working so well and i paused the updater one day and then it just broke forever. After trying incredibly hard to reinstall battle net i just couldnt and gave up. Really sad i cant play natively on steam deck. Might try copying over a full copy of battle.net and wow classic but i really shouldnt have to be doing all this.

Same problem here after I reinstalled the App.

Fresh install of Windows 11 with a fresh treatment of updates and drivers. I’m experiencing this too with Battle.net.

Is this a local service that’s taking a long time to respond or is this trying to connect to an external server that’s slow to respond?

I checked services.msc but I don’t see one called “Blizzard Agent”. I do see “Agent.exe” running (Description of Battle.net Update Agent). In which case, it seems like a bug with this update agent.

1 Like

Yes, I also am joining the ranks of those with fresh installs on everything, firewall turned off, security turned off, all drivers updated, yet the battle.net update agent is sleeping much like the support staff which hasn’t resolved this issue in almost 3 years. Congratulations. I believe it is 100% battle.net having inferior servers not capable of handling the amount users on the servers and/or like Zeddie said a bug with the update agent. Either way, fix the problem battle.net.


Well yeah, count me in on this. I have this Battlenet client installed on three computers, one of them being the Steam Deck. Yes, you might say it’s not supported and yadayadayada. Oh well, i don’t care. It ran all fine until the last update and out of curiosity i pulled out unused SSDs of my drawer, installed fresh Windows 10 for all these systems and guess what? They all run into the same problem. Updating or installing games on Battlenet just does not work or takes ages to start and complete. In fact after waiting for more than half an hour on a download of Diablo 3 to even start, i highly doubt this has anything to do with my ISP, when everything else works absolutely fine. I even took the Deck and a laptop to a friend, installed fresh Windows 10 there on both. And what do you know? Same problem there but completely different ISP and network. The only common thing is the hardware and the Battlenet account. That pretty much tells the story: It’s not the users fault, at least if it’s my account somehow got faulty, which i doubt.
I also work in IT and i know that 90% of the time its user error and i don’T see myself an exception of this rule by any means. But when it’s not small amounts of users anymore, that paints a picture worth looking at. Or at least it should.


I too have the same issue with it plus for odd reason, it won’t let me change my status. When I opened up and logged in, I noticed it logged me in as “offline” which is really odd. I tried to change status, it won’t change status.