Latest Update Breaks Battle.Net Launcher on Linux

this helped me. now it works. thank you very much

sadly not helping me. exactly the same thing happens as without it:

$ WINEPREFIX=/home/deemon/wine.hearthstone WINEDEBUG=-all WINE_SIMULATE_WRITECOPY=1 wine 'C:\users\Public\Desktop\Hearthstone.lnk'
wine: Unhandled exception 0x80000003 in thread 3f8 at address 6DE700E1 (thread 03f8), starting debugger...
wine: Unhandled exception 0x80000003 in thread 4b4 at address 6DE700E1 (thread 04b4), starting debugger...
wine: Unhandled exception 0x80000003 in thread 4fc at address 6DE700E1 (thread 04fc), starting debugger...
wine: Unhandled exception 0x80000003 in thread 568 at address 6DE700E1 (thread 0568), starting debugger...
wine: Unhandled exception 0x80000003 in thread 5ac at address 6DE700E1 (thread 05ac), starting debugger...
wine: Unhandled exception 0x80000003 in thread 5f4 at address 6DE700E1 (thread 05f4), starting debugger...
wine: Unhandled exception 0x80000003 in thread 638 at address 6DE700E1 (thread 0638), starting debugger...
wine: Unhandled exception 0x80000003 in thread 67c at address 6DE700E1 (thread 067c), starting debugger...
wine: Unhandled exception 0x80000003 in thread 6c0 at address 6DE700E1 (thread 06c0), starting debugger...
wine: Unhandled exception 0x80000003 in thread 704 at address 6DE700E1 (thread 0704), starting debugger...
wine: Unhandled exception 0x80000003 in thread 750 at address 6DE700E1 (thread 0750), starting debugger...

wine-8.20 and also wine-8.21

1 Like

That worked for me, thank you.

Thank you, this worked for me!

This thread helped me - thanks.

I wish the blizzard people would at least be nice to linux users instead of just trolling. You guys could at least be professional.

3 Likes

Howdy!

Linux is not supported. That being said, it looks like some players found a workaround Here. Looks like adding: WINE_SIMULATE_WRITECOPY=1 to your environment helps.

Thank you!

1 Like

How about keeping the launcher clean instead of piling bloat on it every update?

It’s not really about supporting Linux, but a simple thing as a launcher shouldn’t be doing so much weird stuff to break and hog system resources all the time. This isn’t only bad for Linux users, but affects Windows users as well, even if it “works” (and apparently it doesn’t, as there are loads of issues from “supported” Windows users as well with the latest update).

3 Likes

Hi. I’m not really good with all this but is this work for Game Porting Toolkit? And do I just add this “WINE_SIMULATE_WRITECOPY=1” in the terminal command?

What kind of answer is that? A week ago the launcher was working without any problem and something was done to it that doesn’t work anymore.

1 Like

You’re asking for assistance with something Blizzard does not support. The blue in the above reply pointed you to their best guess for a solution, but it’s not their responsibility to keep Bnet working on Linux when it doesn’t match their system requirements for the software.

Thank you Blizzard for even bothering to reply to this. I (and most) Linux users fully understand that the platform we use is not supported (sadly, maybe one day?) and that even coming along and replying to this thread is more than a lot of games developers would do.

This is actually a problem with Chrome (CEF). So I don’t think there is anything Blizzard can even do (other than stick to a legacy version of CEF but that would also be crazy) and people will start to see this problem in many other places as well. Its stupid but the entire world pretty much runs on Chrome now in some way.

For WINE_SIMULATE_WRITECOPY to work you MUST be using Proton Wine and not vanilla. The Lutris runner wine-ge-8.25 has this and works fine.

Staging vanilla wine also has STAGING_WRITECOPY but this does NOT work.

5 Likes

Not in the terminal.

If you are using Lutris, right-click on the game then click Configure.

Go to the system options tab at the far right, then scroll down to environment variables at the bottom.

Then do key = WINE_SIMULATE_WRITECOPY value = 1

Then hit enter and save

1 Like

lmao okay, yes this is your answer to alot of your clients

good luck in the future, i will be looking elsewhere like alot of others ----

thank you, you’re a godsent <3

I do not work for Blizzard; I am a player like you. But sure, go off.

There are several people who are posting that Linux isn’t a supported OS. If you use Linux, you probably know that almost no games officially support Linux. This is why Linux gamers post questions are on the forums. This gives us a venue to communicate what we have done to fix those problems. Official forums are best because it helps us get to fixes for the specific game we are trying to play. If you don’t game on Linux, you don’t need to contribute here. Go to another post where you can apply your knowledge.

I have two systems that run World of Warcraft with Battle.net. After the update at the end of November 2023, Battle.net stopped working on both of them. I use Lutris for my management tool and I am using wine 8.0.2 stable. One system was fixed by adding the environment variable “WINE_SIMULATE_WRITECOPY=1”. Kudos to whomever identified that solution.

The other system was still not working. I was able to start the game by running it directly and bypassing Battle.net, but that only worked until a new game client update was required (about a week.) The Battle.net client would crash with an unhandled exception 0x80000003. There wasn’t a lot of additional information in the error logs. I checked several forums, but couldn’t find a solution. Finally, I went to the Lutris website and did a fresh install of the Battle.net client in a new wine configuration. This Battle.net instance worked without any problems. I moved the World of Warcraft folder from the old virtual c drive to the new one and added the game in Battle.net and the game client ran successfully. If adding the environment variable doesn’t work for you, perhaps you can try the nuclear option. Good luck, Linux gamers!

I also want to show appreciation to all Blizzard developers who do Linux gaming. I know y’all are doing your part, even if providing Linux support officially is not economically viable for Blizzard as a company.

2 Likes

If its any consolation, the windows battle.net experience has also been trash since the latest update. Intermittent BLZBNTBTSXXXX errors all week, Linux just launches to a blank window. My work around on Linux and windows has been to delete the Battle.net.14542 from the battle.net install directory then re-launch. this should force the older, working version to launch as long as you still have Battle.net.14494

Sounds like the devs over at blizz should be spending less time polishing Bobby’s many golden boat anchors and more time polishing the software that launches their games.

Okay so I know people have slightly different ways for installing this, personally I had followed [this guide], which uses Wine. EDIT: Not allowed to post links...

Now I added export WINE_SIMULATE_WRITECOPY=1 to my .zshrc file, and verified it was loaded by my terminal. Enabled rosetta, downloaded the Battle.net exe installer, and ran this command to run the installer:

gameportingtoolkit ~/Games/battle-net ~/Games/battle-net/drive_c/users/crossover/Downloads/Battle.net-Setup.exe

The installer popped up, said downloading new files, got to 100%, then disappeared with the process hanging, which was the previous behavior when trying to launch Battle.net. (The icon remains in the statusbar)

I’m not sure how to debug this further, because I’m not sure where any error logs would show up on the system. If someone could point me in the right direction that would be extremely helpful

You can but you need to convert the links to preformatted text – the same way that you converted those words to preformatted text; i.e.:

  • write/paste the link as you normally would,
  • highlight the entire link,
  • click on the </> button (button #6) on the formatting bar at the top of the composition window.

Your link will appear white on a grayish background and will be allowed by the forum software.

It’s not really true Blizzard won’t be able to to fix this without using an old CEF version. This is indeed a problem with CEF, however this particular issue was fixed in CEF specifically so it runs again with wine. exiftool tells me libcef.dll version is 83.0.0.0 on the working 14494 battle.net version, and 108.0.0.0 on 14542 which broke. It is fixed in later released versions of Chromium 109 (last Chromium version running on Windows 7) and all subsequent Chromium releases, so let’s hope this will get fixed soon. (This wine bug has all the information: https://bugs.winehq.org/show_bug.cgi?id=53835)

2 Likes