Immortal cloak non existent

Results for: My character became an immortal for the first time, and didn’t get a default cloak. There is no button in settings menu under general, “immortals” , to equip(or unequip) any cloak. I am the only one who didn’t get a cloak :disappointed:

So, you’re in an Immortals clan and don’t have this option?

Access to the cloak requires you to have completed a certain number of day’s worth of the Immortal questline tasks. From memory, I think it’s on day 3 or 4 of completing these that you gain access to the cloak cosmetic. Have you done those?