I keep getting error BLZBNTAGT00000841, cannot update games

as the title says I keep getting an error that I need to log in as administrator, which I am and the app is set to run as administrator. I constantly get this error and I have a nearly impossible time trying to download or update games that are on the app. When trying to install an update it cycles constantly between “Initializing” and “waiting on another update” no progress is ever made on the update and no other updates are currently active. I cannot play any of the games from my library due to this error. I have read countless threads and tried every solution possible to fix these errors to no avail, please help. I should note that this app is installed on a windows 11 pc.

Not sure if that is the exact error I was getting today, but the issue turned out to be my VPN. I had to disconnect from VPN before it would work.

I don’t use a VPN at all

Create a new Windows admin account or try an alternative connection, like a mobile hotspot. Either there is a permissions error or there is a connection issue.

2 Likes

I have done both as a redundancy check but the issue still persists, I am working with tech support as well to try and resolve the issue. I did swap hard drive locations where the app is installed and it seemed to work until I shut off my computer. when I turned it on this morning the issue was back. I’m at a complete loss as I have done and tried everything short of wiping my computer ( which I don’t really want to do).

What a ridiculous response I am also getting .BLZBNTBNA00000005 when ever the app needs updating and you blame our side or connection when its a buggy app you force us to use.
After a lot of rebooting I can get it to eventually download updates and the game and app are fine until the very next update. So basically at least 2 different error codes with the same issue and the same worthless create a new admin account on our windows PC.

Tried to uninstall the buggy app and it still fails to connect so i cannot get rid of it. If I try to install a new version it gives the same * BLZBNTBNU00000003* error.

I’m also having this issue. I have restarted my computer, removed UAC, and even updated D2R and nothing is changing. I have no games updating now and it is still telling me I’m not the administrator when this is the only Windows account on this PC. Being that I successfully updated D2R with no issue I can only assume this is a server-side problem.

I’m a player like you offering a suggestion.

i’m having the same problem and have tried everything and nothing. it all went haywire when i updated the app.

So the solution I found for this error is as follows: go to This PC drop down to devices and drives, Right-click on Local Disk (C:) Click on Properties, Select tools, and go to error checking, click on check. Your PC will then do a complete disk check and search for errors, once your PC restarts after fixing any errors you should be good to go, I did this on Friday 06/10/22 and the App has been running Smoothly ever since with no errors.

2 Likes

Thanks for reporting back ElJhosho.

As with many tech support cases, the issue was found to be errors on the storage device that Windows manages.

1 Like

The only way I could solve the same problem on my PC was to either update or remove all other games which had their updates manually ‘paused’.

It appears under certain PC setups battlenet does not recognize certain game updates as paused even though they are in fact paused.

Wow SL would not update due to constantly waiting ‘on another update’. The ‘other’ update was not battlenet itself which was updated to the current version. It did not like paused updates on Modern Warfare 2, Warcraft ptr and Warcraft classic. Battnet refused to update wow SL with those other updates paused.

I was able to update Diablo Imm no problem before removing the other games, but not wow live.