HTTP/1.1 504 Gateway Timeout

I executed the following API call without issue at 12:08 , but a few moments later I get a 504 Gateway Timeout, anyone knows what could be wrong?


At the API playground on this website I get the same error, “HTTP/1.1 504 Gateway Timeout” with my api credentials.

Anyone knows what could be wrong?

EDIT: I found out that all US calls go without a issue still, but the EU calls are not. Are the EU api servers down perhaps?

1 Like

I am wondering why I am getting 504 timeouts also, for the past 2 days it seems. All the WoW Profile API calls seem to be taking much much longer than normal. I have not succeeded in doing a full guild scan of ~980 guild members in the past 2 days because eventually the api calls seem to get so slow and return 504 timeouts continually. Blizz could be making network changes in preparation for a lot more beta users in Shadowland Beta next week or maybe it is just my network path from Australia to US/EU servers?

I just found out that the US calls are going without a issue at the moment, and the EU calls are not. So at the moment I think the EU api servers are down or something is happening to them?

Hello there i got the same probleme!
Cannot retrive characters list after oauth callback :confused:

@Grumpmuppet…yes I can confirm that. I am trying to retrieve EU profile data for my EU guild via the eu api blizzard com domain name, and getting the 504 timeouts on that server. Not just getting gateway timeout errors, alll character profile api calls are taking a really long time to respond, so seems to be a bottleneck on the EU server.

@Xang Thank you for comming back to me. It is weird that earlier that hour I was able to retrieve the data without issue (and quite fast even). So it seems to go down and up whenever it wants.

If this continues, I might want to build a fail safe to check if the api is up before calling it haha.

@leone Also EU calls?

Yes EU calls i also had the probleme last night when i tried to sync some achievements to my database.
I did not tested on US I thought that was api call limitation but i tested with few key and it seems happen randomly.

ps : sorry for my bad english

@leone No problem. Pretty sure it is not a api limit thing, because I am barely calling anything at the moment. Maybe 300 an hour. Maybe we can get a Blizzard response on this?

Yeah me aswell

Hope so i think they probably work on the probleme dev team got ticket this morning ahah

@leone Do you mean we got an official response from them that they are aware of this problem?

@Grumpymuppet No it’s just a guess (and kind of bad joke ahah) as the problem happened to me during this weekend.
I guess this morning the devs heard about it!
Or maybe they don’t know and they gonna investigate after read this post

If it was an API limit due to your credentials you would get a HTTP 429 response code. This is probably an instability with the API, reporting on the API bug report forum might be more appropriate.

Just completed a full guild scan of ~980 guild members, doing 7 profile api calls for each guild member, at full speed and no gateway timeouts occurred at all. Each api call was done extremely fast, so perhaps the EU api bottleneck for the past 2 days has been resolved now.

@xang @Schiller @leone

It seems I can also call EU api’s now as well and it seems pretty fast. However since I was able to call the EU api’s as some point this day, it is not guranteed they will stay up that is. But atleast good to know it was not a bug on my part.

Cheers for the help guys!


Greetings all,

As suspected, we experienced some disruptions this morning (US time) with our API services for EU consumers. We believe this issue should now be resolved. If you experience similiar issues in the future please do feel free to report them to us.


1 Like

This is resolved now, but yesterday around 1900 CET I had the same issues as described in this post with US calls instead of the EU calls.