Heroes of the Storm: Can't repair or update

Lately, I’ve been getting that annoying issue where Heroes of the Storm downloads an update every time I close it, which wastes time by applying the ‘update’ the next time I run the game. I tried running the repair tool to maybe fix it, but I got an error message, prompting me to try again.
I tried it three times. I restarted my PC and tried it again, and I get the same error message.
So I closed the app, and the Play button says ‘Update’, but it just starts “Scanning game files” as if I ran the repair tool. I get the same error message after the progress bar fills.

More info:
I use a VPN, but I disabled it in one of my attempts.
This is the error I get:


Hey there NobleShade,

Getting stuck in an update loop and getting the BLZBNTAGT00000BB8 error is quite frustrating. Typically BLZBNTAGT00000BB8 means files could not be written or downloaded. It can be caused by interfering programs, damaged files, permissions, or a connection problem. We’ve seen a bug occur with the Battle.net application and permissions causing this with various games too, with Heroes of the Storm and Starcraft 2 being the most common ones. I’m hoping a quick series of steps can fix the aftermath of what the bug caused can help with this or at least narrow down the cause:

1) Open File Explorer and navigate to your Documents folder
2) Right-click the Documents folder and click Properties
3) Click the Security tab towards the top
4) Click the “Edit…” button next to “To change permissions, click Edit.”
5) Ensure “Full control” is set to “Allow” for all Groups or user names
6) Click Apply and OK

If that doesn’t help, try renaming or deleting the game folder in Documents and then starting the game.

Lastly if there is still a problem, please test an alternative network or hotspot/tether which can help rule out network and ISP issues.

Let us know how that goes. Take care out there!

1 Like

Full control was already enabled.
I deleted the game folder, but it didn’t work.
I also tried it again after tethering my phone, and it didn’t work.

I’m getting the same thing on HOTS and in Wow. Plus wow can’t launch it gets an error with a bunch of IP addresses.

NobelShade - Thanks for checking the permissions and an alternative connection. The next idea on this is to address damaged files with the Battle.net application. We’ll want to uninstall it and clean up any lingering files before reinstalling so we make sure it’s not a factor here:

  1. Uninstall the application
  2. Press Windows key + R and type in %temp%
  3. Delete anything related to Blizzard or Battle.net
  4. Do the same for %programdata%, %localappdata%, %appdata%
  5. Reinstall the application. A fresh installer should be downloaded for this

Sharmard - I’m curious if you were able to try the steps I shared already here involving the folder for Heroes of the Storm and an alternative connection. If the folder is a factor and fixes your Heroes of the Storm launching, then it’s possible the folders used for the World of Warcraft interface is also having a problem and doing similar steps may help. If you’ve tried all this though, then please try the Battle.net application reinstall I list above.

I was able to fix this by uninstalling it via the desktop app and re-installing it.
Now the game works normally, but I hope that annoying bug that downloads an update every time the game is closed gets addressed soon, since it doesn’t appear to be in the PTR notes posted last night.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.