Got gifted Cold War but can't play beta

So the other day my friend gifted me Cold War and I got the email confirmation and collected the gift on my desktop app. However, when I go to play it in the launcher it tells me that I still need to pre-purchase the game. When I also try to buy it again it tells me I already own the game. I was just wondering how I can fix this so I can play the beta. Thank you.


I am having the same issue, but I’ve purchased myself rather than being gifted.

Same issue here. Contacted Activision and they can’t do anything, waiting for a reply from Blizzard. The game doesn’t appear as “active” when I go on my account “Games&Subcriptions”.

Good afternoon, I just received the Twitch drop of early access to the call of duty cold war open beta but when I go to the Blizzard desktop app it won’t let me play


Same here, can’t play the beta…

This is so jank, I was looking forward to trying out the game and it seems like by the time they actually read these posts, let alone get a fix out, the game will be open beta/full release.

I also have the same issue.

Change your password and then it will work. Just tried it and worked.

Yo this actually worked thank you so much

1 Like

How To Get Beta To Work: Open -> Click Options -> Show in Explorer -> Open BlackOpsColdWar.exe and it will open

1 Like

Same issue gifted to another account not showing up as a purchased game

same exact issue. I just want to be able to play the game

Go to

2.Click your Name Go To Account Settings

  1. Go To Account Details
  2. Scroll Until You See Receive News and Special Offers From Blizzard
  3. If its Checked click update then recheck it if not just check it

It should let you play the BETA

All this time, the preorder window could be closed and the game is right behind it. I was pissed and then I seen the ‘X’ on the top right of the pre-order pop-up

Hey there,

The beta access key is appearing on the account just fine. Could you give the instructions I posted on this thread a try?

Let us know how it goes. Cheers!

This worked but damn…how hard does it have to be.