Game breaking bug (PC) Cannot attack or heal

While playing the game today I noticed I was able to get to the end of a Rift within about 2 to 3 minutes however during the boss fight any action taking like spells or healing would result in an X appearing on the screen next to the letter C causing me to fail the rift.

I have no idea what caused the glitch as I’ve never experienced that on android.


I have the same issue.


It’s a wicked fun game with a great story and I love all the dialog thus far.

It’s a beta, things are bound to break so hopefully this report helps those in charge resolve the issue :slight_smile:


no, this is not just a “oh I missed one attack oh well!” you cannot do anything with your keyboard except smash it on your face and table. You have to take a DEATH in the game to get back and be able to attack for 4 or so seconds.

This is such a big bug taking place across so many people here on the forums and even more from people googling the issue. This. is. bad.

The Diablo team is trying to get back at us for the BlizzCon where they bombed announcing this game. THEY HAVE HAD SO MANY YEARS TO GET THIS RIGHT AND WE GET THIS GARBAGE!


This has happened to me multiple times. I came here to report it but saw yours so Ill just add to it.


fix this bug plz blizzard


I want to bump this thread as well. I’m on PC and on the Keyboard and randomly my controls will just stop working and I have no idea why. I have tried to produce the same error with no success. Also getting out of the error consist of me smashing buttons. I have tried multiple things but nothing has helped. Please fix this issue as it is very very annoying.


This has happened a few times to me as well. First time, just had to let the enemies kill me. Second time was in a party in a challenge rift and exited the game and rebooted it, rejoined but the rift was done…was able to use skills again, but extremely broken issue.


Same issue here. I haven’t figured out what causes this consistently yet. But sometimes it comes back quickly, sometimes it can be up to a minute before I can use any of the ability keys. All that I can do is move around.

1 Like

Twice now, I have had this happen. Seems to happen, to me, after/during Ray of Frost.
Run around for a bit and it’s back to normal.

1 Like

I’ve run into the same thing several times. It seems to happen around using channel spells (Ray of Frost, Disintegrate, etc.).


ive noticed it with ice beam. once it happens if i can quickly double click the key for ice beam again it seems to clear the issue for a time. not sure what causes the initial bug to proc yet.


This happens constantly for me. Basically makes the game unplayable. I’m playing on Wizard and thinking about it, it does seem to be after ray of frost so possibly an issue with channelling abilities not cancelling properly.


Yeah i cant even play the game bc of this.


I play as wizard, same thing.
I cannot interact with objects or mobs, nothing. It usually unlocks itself after few minutes but for these few minutes I can do nothing but flee. I play with another person so I must rely on them killing the mobs while I’m waiting for skills to come back.

“cancel” option appears while pressing a button corresponding to multistage skill but besides that, nothing happens.

Fine on ipad though


It looks like using the channeling skill (Ray of Frost) re-activates the skills again after they have been disabled.


I play as a Wizard, and I experience the same.

All of the sudden, I can’t attack. Each time I hit any skill after triggering the bug, a new icon appears, bound to the letter C, with the word “Cancel” with a big red cross in it.

I try to hit C, but it makes no difference. I try to click the icon, but it makes no difference. After smashing all my keys for a good 10 seconds, I’m able to attack again.

I play Wizard, and I have the following skills:

  1. Ice Crystal
  2. Scorch
  3. Lightning Nova
  4. Disintergrate
    Auto-attack: Magic Missile

I have rebound my attack to Right-click and movement to be Left-click.

1 Like

I also have the same issue. Just wanted to put this on record, as its game breaking at the moment for me. I am on PC

1 Like

Having same issue with original key bind config. Game will ignore all inputs other than click to move/wasd. Sometimes action will work after 5-7 seconds of fervent clicking/button smashing, but usually have to die or exit game. When inputting actions while issue is present, you can see the Red X/Cancel action option on the right hand side, but does nothing. Barb cyclone build.


Same or similar bug playing as Sorcerer, seems to happen when casting multiple spells quickly, particular when casting the beam spell. Cannot heal Q, cannot attack LMB, etc.