Full Game Bugged

I upgraded my World of Warcraft account after 7 years of not playing, I wanted to add game time. I tried to do it in-game, but got logged off (long difficult password which wouldn’t c/p), so I did it via the web store instead.

I can now play past level 20, my character is currently 27. I have the option to level to 110 and 120. However, I cannot create groups, cannot sell on the AH, cannot use the mail system. I upgraded to the expansion which gave me the battlechest including BofA, along with 30 days of game time. The in-game shop is now bugged as well, shows nothing.

I have tried closing Battle.net completely, and logging into a different account (in the same Battle.net account) as well as Rebooting. I even logged off for an hour to see if that would get it to work. Nothing has worked so far, to allow me to send mail or sell on the AH. I am very frustrated, my bank is filled, and I can’t use an alt to store items.

Oh, I also have access to the new mount.

Can a GM help me here please?

I gift overwatch but its not working i waste my 32dollar