Freezes on hovering on unitframes or on using shift/alt/ctrl

Hello! After a recent update when you hover on the frames / models of players or with a simple pressing of the Shift/CTRL/Alt modifier keys, simply incredible hangs occur. If you constantly guide the mouse for example, for example, when you play a healer and treat the players in the group, the number of frames per second falls from 30 to 10 or less. That is, if you play a healer when constantly it is constantly moving between players, the game will be constantly constantly in a state of hanging. Each guidance on the player’s frame, models of players or in-game characters, even if you don’t do anything in the game, that is, out of activity, out of battle, do not move, do not inspect the world around yourself, but when you press modifier keys, it causes a significant performance drop. Even when you play alone, playing even one target becomes extremely difficult.
I am a web developer with 10 years experience. I can program on Lua, I can write and maintain addon, I can write complex macros, use commands /fstack and /etrace, as well as use the profiling tool built into the game. My usual work troubleshooting in the work of web applications, I decided to look for a problem myself and spent about two hours.
I renamed WTF folders, Interface and deleted the Cache folder. Used the command Check and Restore, in Launcher The problem was not resolved.
The result of the investigation is next. I have many macros with different conditions. For a dried healer, unfortunately, without macros, it is impossible to play especially when changing the appearance. Lags arise in those moments when these macros are on the panels. What is the most interesting and strange, you need to remove macros even with the panels of the inactive form of the Druid. That is, if you play in the form of humanoid, as long as you do not delete your macros from the spell panels at the active form of a cat and a bear, gesturing delays will still take place. Technically delays occur when the event “actionbar_slot_changed” event arrives from the server. If you set the macro to the static icon and remove #show and #showtooltip metaparameters do not allow the problem.
That is, the problem occurs, or when you request the server to execute a macro, or when processing a macro before sending to the server or when responding to the interface response from the server.
This concerns macros in which the [@mouseover] condition and [modifier] condition are used.
As soon as you delete from the panels, all macros with these conditions, when you hover in characters and when using modifier keys, do not happen more.

It seems to me that the processing of the query is high-priority, as the use of macros is common and cannot cause such malfunctions. And for users of the game / players using macros, it will be quite difficult to deal with the reason for the appearance of such a problem if they have no special knowledge. Reporting the essence of such a problem to the respected Game of the Master will be difficult without having experience and knowledge.
Just in case I will write that the Internet speed is 200 megabit per second. The problem appeared precisely after the update and never manifested during the last 5th - 7th anniversary of the playing in World of Warcraft, when using such macros in the interface there were no such problems.
The problem was both yesterday and today in the morning. I think the problem is not related to the fact that many players have come to play new game content that have become accessible after the upgrade, although I understand that it is a fortune telling.

Regards, Ivan.


Wrong forum. This one is for the web API. You must post this over the Macro and UI category in the WoW forum.

Schiller, I’m really sorry for posting in a wrong forum. I spent 4 hours of my life, to test this issue, and I tried to use forms on blizzard/or/ web sites, I tried to do that on support forum, and one one guys there said me to post here. I just can’t imagine why I’m paying for the game, I can’t play because of bug, I found an issue, I tested it, and I can’t reach game master or someone who well get technical information that I get. Why I should when I’m wery tired, to find the right forum, and why no body just trying to connect me with the right spot instead of saying something like this is the wrong forum. I made mistake, and I’m sorry for that, but this is definitely bad practice of supporting.
It’s just not possible to share an issue with developers directly into bug tracker when you are developer, so you can determine whether it’s game bug or not, but you have to broke your eyes, to make suck simple action, and you will game unsupportive message you are in the wrong forum. Sometimes I can’t believe that I’m playing in this game for 12 years and payed so much money for that just to see messages like that.

The system doesn’t allow me me to send feed back, it have offered me to read interface forums and it have offered me to read some other forums, or it offers to send feed back, so I’m pressing to send feed back and this circle starts again.

I’m sorry anyway.

Can you be more specific on which “support forum” ? Whoever said anything about the API forum is wrong because the Blizzard API is not related to in-game stuff.

Just to clarify. I’m not related to Blizzard. MVPs are regular players who dedicate part of their time to help the community over the forums and get a green name as recognition for their efforts. We have no open channel of communication or any other perks aside from the forum colors.

Feel free to wait for a better reply here, but you’ll probably get a faster answer by going to the proper forum or opening a support ticket.

Can you be more specific on which “support forum” ?
World of Warcraft bug tracker or forum for sharing such kind of technical problems, not related to addons.

Whoever said anything about the API forum is wrong because the Blizzard API is not related to in-game stuff.
Here it is where the person said that.

My objective is to share the technical problem related to how game started to work after new content become available. The problem is that it happened not in new content, but in previous one, while all addons turned off and cache folder and wtf folder moved.

Just to clarify. I’m not related to Blizzard. MVPs are regular players who dedicate part of their time to help the community over the forums and get a green name as recognition for their efforts. We have no open channel of communication or any other perks aside from the forum colors.

People often make this mistake. The API forum is about web APIs.

This is usually the best forum for Lua API:

I hope this helps somehow.

Dear Schiller! Thank you very much for this time spent on me. Some person finally made post here and other guy from Russians Gordunni game server made the same thing in that thread.

Problem, that I have to spent more time and get 10 level of character on us server, to have an ability to make threads there. At the moment of posting I’ve spent probably 3 hours on this. And I spent may be 4-5 hours on retries of how I should and where I should post messages about this kind of issues, it turnes that I have to create character and spent an hour to write something. I need some break from this.

I will be so great if on forums, there will be special place to create issue requests, which will be opened and will be available for guys from other region, without need to create character in us region. The same way as it is happened for git hub, or git lab, where peoples can share theirs code, and theirs experience. This forum must be available after short knowledge/understanding check of the person which have to send some information about an issue, to filter guys who doesn’t understand how game interface works.

At leased even that forum that you have shared with me, should allow to post bugs from persons from other region, who already have characters of level 10-th or greater.

Again, thank you for your time, and reading my request.

With great respect, Ivan

Developers has made fix. At leased with that type of hanging that I’ve met, problem was resolved.
Thread can be closed or deleted.

Best regards, Ivan