'Fixed' D2 Cinematics Not Showing - Sven Glider

Don’t really know the workings of it, but using the latest Sven Glider and now my D2 Classic Cinematics are playing. Thanks to the other thread for mentioning the Glider.

A few questions on the Glider however, to whomever can help. I didn’t change anything on the Glider’s ‘Settings’ Tab- left everything default (VSync ON), but I checked everything on the ‘Renderer’ Tab :-

  • Texture-Memory set to 64 MB
  • 1024x1024 Buffer-Texture-Size
  • Enabled 32-bit Rendering
  • Enabled Textures for Videos
  • Enabled Bilinear Filtering
  • Enabled Supersampling
  • Enabled Shader-Gamma
  • Enabled ‘No Gamma’
  • Enabled Desktop Composition

I am using AMD Radeon HD 7960M ‘Whistler’ XT (Circa. 2011) 2GB Dedicated
(Actually Radeon HD 7690M XT is Thames XTX, AMD FirePro M5950 is Whistler-XT ???)

Q1) If I wanted best visual quality over performance, should I have checked everything as above? Would you have left anything out and why?

Q2) If I enabled Shader-Gamma, should I have enabled ‘No Gamma’ as well?

Q3) Should I have enabled Desktop Composition? Will the wrapper compliment microsoft desktop composition or is it better i turn composition off to ensure all wrapper effects work as intended.

Thanks in advance.

Turn off desktop composition and no gamma.

If you plan on running Window mode, make sure and tick “window-mode” in the glide wrapper settings as well as adding the “-w” command switch to your Diablo 2 shortcut. Also tick “captured mouse” that way your mouse doesn’t run off the edge while in window mode.

If running full screen, tick the “desktopresolution” option and make sure you don’t have the “-w” command switch on your game shortcut, that way your screen doesn’t have to switch resolutions starting and exiting the game. Also tick the “keep aspect ratio” so it doesn’t stretch the image to cover todays wide-screen ratios. It will just make black side bars.

The visual quality can’t be improved beyond what Diablo 2’s 800x600 already is. The only thing this wrapper will do is upscale the image to fit in a higher resolution and smooth the pixel edges.

Performance wise, even your modern budget graphics cards can run this with little trouble, so I wouldn’t worry about that.

HI darkjedi, i’ll try unticking composition and no gamma.

i can’t tick ‘desktop resolution’ though, i will get the black side bars you mentioned. ‘keep aspect ratio’ is already ticked by default.

i don’t play on -w windows mode.

After i start off the glider once, could i close it until my next reboot? it’s still in memory i noticed

Not sure what you mean by starting glider once… Are you talking about the glide-init program?

ya that one. oh i see what you mean, it’s just settings. i moved all the contents of the zip into d2 directory.

but i cant tell if turning off composition does anything. anyway i’ll take your word for it. at least now i have cinematics.

I would link you to the Blizzard forum post that has a detailed listing of the settings for the wrapper, but it appears that Blizzard has removed the old forum all together and the posts along with it. :frowning: