Bought D2R. Trying to install it for 2 days now but can’t download the app. Have used two different computers on two different ISPs in two different homes. DL cancels after 1MB of 4.6MB for Network Error across multiple browsers. Firewalls wide open. 100+ Mbps tests and 60 ping to your patch sever (which your website won’t let me type out).

Just tell us what’s up.

Hey there Tiffany,

That sounds quite odd that you can’t get the installer to even download for application. We have seen this happen some times and using an alternative link has helped. We have a forum post dedicated to this exact problem with the appropriate links here.

If there is still a problem, please do get a ticket submitted so we can take a more personal look into what may be going on.

Well, I was able to get your installer from cnet. I had previously tried several different blizzard links posted in other replies with no success. Luckily there were no issues downloading Diablo 2R or connections issues after installing the Cnet hosted client. Thanks!

This is happening again. Multiple computers, multiple ISPs, etc.

Your alternative download link is over HTTP, which is very insecure.

Happening to me on my brand new pc, I guess Blizz really does want me to cancel my account for good.

1 Like

Same issues with and starcraft not downloading, reset modem and computer and its downloading, Bothered me that it worked on a different till I found this article about power cycling

Same happening to me, couldn’t update any of my games, tried uninstalling and downloading again and also couldn’t and now that i uninstaled the i also can’t download it back.

Did u guys find any fix?

I HAVE THIS PROBLEM HERE IN BRAZIL !!! Please help me! I can download all games but SC 2 i cannot! When i try to reinstall all, i cannot download bnet app too !!!

1 Like

Same Problem Here on Brazil 2. I could not update my game, uninstalled it , but the new installer does not advance.
In windows task manager it shows no internet traffic from app at all.
All other softwares are running ok .

Same here, i’m in Brazil.
I installed the client downloaded from CNET and I can’t install any games.

I have an open ticket but they can’t solve it