Diablo Immortal PC keeps crashing

The game opens. It gets to the server select screen. When i click “play” it says “Connecting…” then crashes :confused: .anyone else having this problem? I am gonna try to reinstall the game but i am open for suggestions!

17 Likes

Same issue for me. I did not find the solution.

1 Like

I am reinstalling it atm to see if it helps. Ill let you know if i find a fix.

1 Like

I had this issue, not having afterburner running at launch fixed it for me (I could enable it after the game was running)

Same issue, never found the problem. Reinstalling made it update completely, launch to character screen, then immediately crash and start the Play/Crash loop again

1 Like

Ditto, exact same problem. Would love a fix.

I do not have afterburner but i reinstalled and i am now playing as i type. I do not have afterburner but you you do try the solution above first :slight_smile: if it isnt afterburner then i think it was a pre load malfunction

1 Like

Check and make sure you have enough space even AFTER downloading the updates. It finally worked after reinstalling with enough space. WOULD NOT work before reinstalling, even with enough space.

I did change the hard drive to another, but it was same type

Welp it started doing it to me AGAIN… I logged off just to go eat dinner and when i try to log back in BOOM another crash loop

2 Likes

Game crashed and closed by itself, when restarting, it ran an update and then closed again. It doesn’t open anymore. I’ve already reinstalled and checked for an error and so far nothing. Need help.

3 Likes

Exact same problem here. Launches fine and I can choose a server but as soon as I hit play it crashes to desktop. I tried repairing and reinstalling. My husband is playing fine so I guess I will watch his game wistfully for now. :frowning:

I had pre downloaded Diablo Immortal started it up the first time, had it do a small update then after I picked a server and like the others in this thread, when I hit play, it said "connecting" and quit.  I uninstalled and reinstalled the game and it worked fine after another small update (seems like the preload was an issue).


  After playing for a few hours with no issues, I logged off.  Now when I try to play, it finds an update and downloads 3 files (which it did not do before when it worked) and now when I try to start, I get the same "connecting" followed by the quit.  Maybe it's related to those 3 files or some recent saved settings from my last play through?
5 Likes

Yes, same issue here, I have a post kind of just like this.

 Just an update:    After a bunch of times having the computer quit on me when I tried to play, this time I started it back up again and chose a different server and it let me pick a class on the new server.  I exited the character selection which took me back to the main menu.  I then tried the server my character was on, it worked fine.
4 Likes

I cant even get to that point, it crashes soon after the 0/3 goes to 3/3 and the game goes full screen, says game starting, that screen lasts about .5 se3conds before it crashes back to desktop.

8 Likes

the game opened up and i went to connect my mobile and PC accounts and did the restart the game asked for after linking mobile an PC an now it just does crashes when starting now. i also ran the repair tool and still have the same problem

How can this even remotely be called a beta. This game crashes on PC, full stop. I haven’t yet been able to play and I have quite a high end PC with latest Windows 11 updates, latest NVIDIA graphics drivers, and reinstalled the game…twice.

Blizzard, seriously, if you’re going to create a p2w game, it should at least work. I mean, don’t you guys have PCs? :wink:

12 Likes

Another update: It seems that when I start up the game, if I don’t try to create a character on a new server, the game just start to connect and quits. It also has to be a server that I’ve not tried to logon to before (even just to create a character). Maybe there’s something wrong with a file that saves information upon login to each server?

Same here in my pc The game random close alone without any notification

At me once it was started and began to close too. Just after the “launching the game.” For me has helped cleaning folder C:\Program Files (x86)\Diablo Immortal\LocalData\Cache

1 Like