Diablo immortal pc issue

unable to launch game due to not being able to click the play button!
this button is darker and states this error: BLZBNTAGT000008A4
i have tried to update, it tells me to check my connection… lol

i did try the repair option, but led me to connection issue and above error…

restarted pc, no antivirus installed…
relaunch has same issue.

reinstall has same issue.

tried to install the beta launcher, and did. same issue.

i can connect via mobile but thats not where i want to play at all…

This error is a connection problem on the machine. That can be it’s blocking the install/patch, it’s blocked on the network you’re using, or a few other reasons. Check the help docs for steps to fix it:

Thank you for your reply!
i Have tried this troubleshooting steps from your site and a few self diag too…

sooo it turns out it is not a me issue or a blizzard issue!!

tl:dr
att messed my connection up

my internet is being filtered by my isp “att”!
i even have all settings on my “modem” routed through my router 3rd party.
firewall and everything disabled on modem that manages it! completely passed through.

my router says no issue at all, but i have been having issues connecting to other services as well!

so i have the availability to be able to use a comcast isp as well in the same place.
lo and behold it works as wanted!

im sorry for the post but id figure i would let you all know how i established a connection agian!

att is filtering my line at their infrastructure, beyond my control.
switching to comcast modem isp enables me to be able to connect just fine!

att support was useless, i have dropped att as of today because of these issues!

1 Like

Thanks for reporting back.